Discussions

Premium audio. Made simple.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Philomorph
Level 9

New Streambar Pro playback issues - need help before I have to return it

We bought a new Streambar Pro a few weeks ago to replace our Roku 3, which still works, but is getting a little long in the tooth anyway.

For the most part the new unit works fine, but we have an intermittent problem that sometimes makes shows unwatchable.

It mostly seems to happen in the Apple TV+ app, but also happens occasionally with Amazon Prime video and rarely some other apps. 

The problem seems to happen if the video would buffer, but unlike all our older Rokus that give a buffering animation, the audio starts crackling, then cuts out while the video keeps playing. Then the video will start to stutter. The remote becomes unresponsive or slow. If I hit the “quick rewind” button sometimes it works, and sometimes the Roku acts like I pressed it even if I don’t touch the remote - it will back up to where the problem started and start playing the video again.

Often it will do this repeatedly, never progressing very far, retrying over and over until we exit the app. If we exit to the main menu the problem may or may not go away. Rebooting doesn’t always help either.

We can’t tell for sure if it’s a network/buffering type issue since it never says anything to that effect, or if something else is wrong. We’re kind of guessing this because it most often happens when we try watching a brand new episode of a popular show, like Ted Lasso, right after it comes available.

We have high-speed DSL with consistent downstream speeds of 40-50Mbps, and it happens even if nothing else is using our internet at the time. We started with the Soundbar on WiFi, literally 3 feet from our mesh network router. But as a test I also plugged it into ethernet via the recommended USB adapter. It didn't make an appreciable difference.

I’ve also tried reducing the display from 4k HDR at 60 (which our TV supports) down to 1080p, just to see if it was some kind of bandwidth problem, but it didn’t help.

Honestly we’re about to return the unit and just go back to the Roku 3, despite the lack of 4k support, because we’d much rather see an occasional buffering animation than what’s happening now.

Any suggestions before the return period ends?

15 REPLIES 15\
Philomorph
Level 9

Re: New Streambar Pro playback issues - need help before I have to return it

FYI - I've gone through the basic troubleshooting steps myself, and again with a chat agent, which ended with a factory reset. I'll report back whether it makes a difference.

GaryGuthrie13
Level 8

Re: New Streambar Pro playback issues - need help before I have to return it

Did it make a difference?  I'm having similar issues with the Steambar Pro trying to run the Xfinity Streaming app (and some others), which works fine on our other Roku devices .  I just swapped back to my previous Roku player where I had my Streambar Pro installed to see if the issue goes away. 

GaryGuthrie13
Level 8

Re: New Streambar Pro playback issues - need help before I have to return it

The Streambar Pro is definitely the issue.  My Roku Ultra plays the Xfinity app and all others without any issues.  We get freeze ups randomly with the Streambar Pro.  Too bad as we really like the audio but aren't sure what to do.  Sounds like a factory reset is in order, but then I have to re-authenticate to all of my apps.  Pain in the **bleep** and most likely the same issue.  ;(

RokuKariza-D
Roku Employee
Roku Employee

Re: New Streambar Pro playback issues - need help before I have to return it

Hey @GaryGuthrie13

Thanks for bringing this to our attention.

Could you tell us the specific names of the channels you are accessing on your Roku Streambar Pro that is experiencing the issue? 

If you haven't tried yet, you can remove one of the affected channels then re-install it. To ensure the process is successful, make sure to restart your device before adding the channel back in. We would recommend doing this from the Settings menu by navigating to Settings System System restart > Restart.

For detailed instructions, refer to this Support link: How do I resolve channel playback issues?

We look forward to your response.

All the best,
Kariza

Kariza D.
Roku Forum Moderator
Philomorph
Level 9

Re: New Streambar Pro playback issues - need help before I have to return it

I was unable to resolve the issue with help from support and the internet, so I returned the unit.

I'm now just using the built-in Smart TV apps on my Samsung TV and they work great - no problems at all.

ArielPintado9
Level 7

Re: New Streambar Pro playback issues - need help before I have to return it

I’m having the same problem. At first I thought it was a **bleep** hdmi cable but I purchased a high speed one and still get the same issue. And not just in apps, on the home menu as well. It will randomly glitch with a weird soud (sounds like  if you where disconnecting an aux cord from an a large speaker with high volume) it concerns me that it will damage the speakers because I bought the whole set (side speakers and subwoofer) everything sounds amazing but it does glitch like that and very often. Sometimes movies won’t play because of it. It’s like when a computer does not have a proper processor to run a game or something and randomly crashes but for like 1 second also screen blacks out sometimes at the same time the glitch noice comes up. 

ArielPintado9
Level 7

Re: New Streambar Pro playback issues - need help before I have to return it

I think you guys got really bad bugs on the software and that’s what’s causing this. Please help soon. 

GaryGuthrie13
Level 8

Re: New Streambar Pro playback issues - need help before I have to return it

The problem occurs most often in  the Xfinity Stream application, but that may be because we watch most of our TV (live and recorded) from that app.  We've had freeze ups on NetFlix as well.  We have had no issues with the Xfinity Stream app on our Streambar (the short one) or our Roku Ultra devices connected with the same HDMI to the same TV.  We've tried switching to an Ethernet (wired) connection with a compatible USB  to Ethernet device, but still see freeze-ups. I've tried uninstalling and reinstalling the apps, and checking for software updates.  Nothing so far has worked.

So, before throwing this device into the dumpster, (I haven't been able to get in contact with an actual support person at Roku....very frustrating), last night, I performed a factory reset, and started to reinstall the apps.  I reinstalled the Xfinity Stream app first and watched some recorded show for 45 minutes and some live TV.  No freeze-ups.  I installed a few more apps (NetFlix, HuLu, AppleTV, and PrimeVideo) and didn't have a crash yet.  Intermittent problems are the worse, but I know that the issue is with the SoundBar Pro having substituted the SoundBar (regular) and Ultra with all else being equal. It's a really nice product, so I'm hoping that I can get it working.   

lunchbox12682
Level 7

Re: New Streambar Pro playback issues - need help before I have to return it

Just wanted to add another data point. I've had the streambar pro since June. In the last month or so, Netflix (only Netflix) has the issue. No fixes so far.