Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Network issue with Disney and Amazon app only

Hello  guys,

I'm using this TV :  TCL 50S425-CA

I'm having a nework issue on 2 apps only :

- Amazon prime shows an "Internet Connectivity Problem" when I run the app for 30 sec, then this message vanishes and the app starts normally and is working.

- Disney Plus does not work at all, when I run the app it displays the logo for 20 sec then shows an "Error code 42" related to internet connection too, and it keeps being stuck there.

Other apps are working fine : Netflix, Youtube, AppleTV, Spotify etc even if some apps take some time to start (spotify almost 45 sec) but I blame the TV hardware.

I don't know what to do, I've tried to remove the apps, reboot and re-install them again, I also tried to reset the TV to factory defaults 2 times.

I did some bandwitdh test from the TV built-in tool :

- Wifi 32 Mbps

- Wired to my Videotron router directly 37 Mbps

My computer is connected with 120 Mbps so I guess the 37 Mbps are capped by the TV network card but still it should be enough.

Do you have any idea how I could fix this ?

Thank you,

Ludwig

 

2 Replies
Highlighted
Level 7

Re: Network issue with Disney and Amazon app only

I'm having this same problem. Did you ever get a reply?  In my case the only thing I can think of is that I installed a netgear orbi mesh that might have caused the problem.

0 Kudos
Highlighted
Level 7

Re: Network issue with Disney and Amazon app only

Hello, this was totally related to my Videotron router, a friend of mine gave me his own Videotron router and then it was all good. I guess mine was defective. Since I changed it all my apps are loading well and quickly.

I hope you'll find a solution !

0 Kudos