Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Gaidzahg
Level 7

Re: Major gaming lag after update

@Facehead I want to try what you recommend, namely

"I simply went to the main TV settings (from the home screen), "advanced system settings", then "factory reset" (don't select this!), and finally select "reset tv audio/picture settings ". Once this is done,  simply hard reset the tv, and there you have it! Since doing this I haven't seen the issue in two days, whereas before it would pop up every time I would change inputs."

but I'm a little confused—you say don't select "factory reset", but what's a hard reset if not a factory reset?

0 Kudos
Melody3
Level 7

Re: Major gaming lag after update

I have been having the same problem. I plugged in my xbox 1 to the roku tv for the first time yesterday and it is running terribly. Like you said earlier, there is a delay that makes playimg really bad. The graphics are great but that delay really screws with the experience. I plugged it into my sisters tv afterwards to see if it was my xbox and it worked perfectly on there.

0 Kudos
ukor_YSp5zN3l
Level 8

Re: Major gaming lag after update

I’m also having this issue. I two TCL 65R615 TVs sitting right next to each other, and only one of them is having this problem after a recent update. Both run the same firmware, I’ve tried changing inputs, and I’ve even factory reset the TV having the issue.

After switching away from our “Xbox” input or shutting the TV off, game mode does NOT persist when going back to the Xbox input or powering the TV back on. The menu says it’s on, but I assure you it is not.

The only workaround is to go into the System>Power menu and restart the TV. Then, game mode only works until the inputs are switched or the TV is powered down (into the fast start mode). When that happens, we have to go through the restart process to get game mode to work again.

I have not been successful in trying to to roll back the firmware. TCLs support is difficult to reach. Hoping for a resolution soon.

0 Kudos
nickrep
Level 9

Re: Major gaming lag after update

Hi all, wanted to give a solution update.

The issue still persists, but I have upgraded my sound system to where I do not need to use ARC anymore. Plugging the console directly into HDMI 1, or directly into the ARC port (whichever is true on your end) solves the problem. 

Obviously, if you need to utilize ARC, the problem will persist.

0 Kudos
ukor_YSp5zN3l
Level 8

Re: Major gaming lag after update


@nickrep wrote:

Hi all, wanted to give a solution update.

The issue still persists, but I have upgraded my sound system to where I do not need to use ARC anymore. Plugging the console directly into HDMI 1, or directly into the ARC port (whichever is true on your end) solves the problem. 

Obviously, if you need to utilize ARC, the problem will persist.


Thanks for the tip, but unfortunately, that didn’t work for my specific model/unit. I’ve now tried all inputs with no success.

0 Kudos
nickrep
Level 9

Re: Major gaming lag after update

Dang. I feel your pain. This problem is really aggravating. Have you tried calling TCL? I spoke to them and went through hours of troubleshooting but gave up. They needed to compete all of the troubleshooting before it gets logged as something that needs investigation. If you have the patience, I recommend calling them and doing all they ask. This way it’ll get taken seriously.

0 Kudos
MikeKelehan
Level 9

Re: Major gaming lag after update

Just want to add my voice to the choir, I'm having this problem too. Doing a system restart through the menu fixes it temporarily, but I have to do that every single time I change inputs, which is a lot. Very frustrating.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Major gaming lag after update

Hi everyone,

Thanks for the posts and information.

If you are still experiencing this issue, can you please provide us with the following information:
-Roku TV brand and model number
-serial number
-device ID
-software OS/version
(these can all be found in Settings > System > About)
-what device are you connecting to your TV and through what kind of connection (HDMI/AV)
-are you using any video modes on your TV when you experiencing this issue?
-when did you start seeing this issue?

Once we have this information, we will be able to pass it along to the appropriate team to look further into.


Thanks,
Danny

Danny R.
Roku Forum Moderator
Tags (1)
MikeKelehan
Level 9

Re: Major gaming lag after update

Thanks! Here's that information:

-Roku TV brand and model number

Roku TV 7120X

TCL model 55R617

-serial number

YS00TD811419

-device ID

FV284T811419

-software OS/version

9.3.0 built 4194-30

-what device are you connecting to your TV and through what kind of connection (HDMI/AV)

Xbox One X through HDMI 2.0

-are you using any video modes on your TV when you experiencing this issue?

Game Mode is always on

-when did you start seeing this issue?

It's hard to pinpoint, because I wasn't playing games during the early months of the pandemic. I started playing games again in early July, noticed immediately, and hoped that it was a temporary bug and the next system update would take care of it, but it's still there. It could have started right in July, but it also could have started as early as March.

More info:

Gaming latency was great until this happened. Now, there's only low latency immediately after a full restart (choosing Settings > System > Power > System restart), but if I use any app or switch to another input, when I come back, the latency is high. If I do a normal power down (just pressing the power button on the remote, then turning it back on), latency is high again. The only way for games to be playable is to do a full restart at the beginning of every session.

According to the TV's menus, Game Mode is still on. Switching it on and off makes no difference.

0 Kudos
ukor_YSp5zN3l
Level 8

Re: Major gaming lag after update

I appreciate your help! Here's the details of my setup:

-Roku TV brand and model number

Roku TV 7121X
TCL 65R615

-serial number

YS00FP794426

-device ID

FW293F794426

-software OS/version

9.3.0 built 4194-30

-what device are you connecting to your TV and through what kind of connection (HDMI/AV)

Original Xbox One, HDMI cable, HDMI 2.0 setting

-are you using any video modes on your TV when you experiencing this issue?

Normal video mode, Game Mode on, all the other processing stuff off

-when did you start seeing this issue?

I want to say July 2020, but I don't have the exact date.

I have two identical TVs with two identical setups (original xbox one via HDMI, same settings, mode, etc. etc.), and only one of them is experiencing this issue. This one has this issue across all inputs. A picture setting reset nor a factory reset has solved the issue.

I've even tried a different HDMI cable, and the problem persists. Simply changing the inputs or going home then back the xbox input somehow disables game mode (despite the menu saying it's on). The only way to resolve is to perform a system restart - where the setting persists until the input is changed or the tv is powered down. Then another system restart has to be completed.