Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Loop start up then turns off and backlights work well

Need help how do I update firmware on 58 in an the tv when tried to turn on through phone says eco mode

0 Kudos

Re: Loop start up then turns off and backlights work well

Not sure if this will work for you, it’s a combo of what I tried this week, TCL Roku tv.  

It got stuck in the boot up loop following a failed update, showing the logo start up screen, processing for a while, turned itself off, then back to logo screen, repeat endlessly.  The update cannot apply if it cannot finish the boot up on restart.  

Since I could not get to the home screen, I could not access any setting or even easily do a factory reset.  I have done every combination to get to a menu:

I found the physical power button, held it. Nothing.  

Found the pinhole reset button that needs a paperclip (I use a wooden skewer) to poke it.  Various instructions are listed for this button.  

One is just to press it and see if the loop stops.  This did not work for me.

One is to press it quickly 4 times and then press a 5th time but hold the reset button for 30 seconds this time.

One is to hold it 30 seconds, unplug TV, while still holding the reset button, plug it back in. I think this worked at one point.  I managed to get to the screen for a factory reset, and clicked it, then it got stuck for several hours of me trying to get back to the initial recovery set up screen where you start by picking a language.

What seemed to work to get the update applied:

1. I learned it seems to help to unplug it, and hold the physical power button for a minimum of 30 seconds, then plug it back in DIRECTLY TO THE WALL.  

2. This took me to the initial set up screen, as if I had just turned it on for the first time.  

3. I started set up, but DID NOT chose ‘set up for home.’  Following a Reddit post, I chose ‘set up for store use’.  This seems to be like opening Windows in ‘safe mode’ by pressing F8 as it turns on.  In store mode, it applied the update.

4. I was too scared to try to re-set up the tv in home use mode, so I attempted to keep using store mode, but this is unstable for normal viewing, and apps would not load, screen settings would not save.  

5.  It got stuck tonight unable to play Pluto, so I tried to clear the cache and did the remote soft reboot code just like a 1990s fighting game (Press Home 5 times, Up, Rewind x2, Fast-forward x2), and it did not like it.  It went back into ye olde reboot loop, until I yet again unplugged it, held the power button 30 seconds, then plugged it directly into the wall.

6.  I set it up normally when the initial set up screen came up, set it up for home use, and checked the update… it had applied while in store mode, so it now ‘seems’ ok in home mode.

Maybe this will help?

0 Kudos