Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nickaz
Level 7

Re: Channel guide stopped working - "No Data Available"

I re-entered my Zip Code and that did not help. So I entered the Zip Code of the area just north of me and the Channel Guide worked again. I entered my correct Zip Code back and it stopped working again.

I left it with the incorrect Zip Code and it's still working.

So I suggest just putting in a different Zip Code from your area. 

bugtussle
Level 8

Re: Channel guide stopped working - "No Data Available"

I'm having the same problem on my TCL 50" 4 series. No guide for about a week now, I hope there is a fix soon.

0 Kudos
Mark_H-
Level 9

Re: Channel guide stopped working - "No Data Available"


@RockyRokoo wrote:

I’ve had the same issue and I tried every suggestion on the web that I could find. This morning I changed my zip code to a more “major city “ closest to me and the smart guide populated fine after I did a a system restart. I then put my original zip code Back in and no data. Maybe the place they are pulling the data from is dropping zip codes? I don’t know but it worked for me. Hope it helps.


DITTO! Getting rid of YouTube TV because of the second price hike. Bought an antenna (going to get Sling also), installed in attic and had 47 channels coming in great. But couldn't get the guide to come up with any of those "fixes" in the other thread that's closed. I then thought it may have been because I turned off the "smart" features that pull data from what you are watching. Wasn't that. Changed my zip code to another of the same city I live in and it worked. Changed it back to my actual zip code and the guide went away. Something is definitely going on. We will see if it holds, I am only on day one of using OTA.

Moral of the story: Try surrounding zip codes if your actual zip code doesn't work. 

0 Kudos
RickRae
Level 7

Re: Channel guide stopped working - "No Data Available"

Just wanted to say thanks for this.  I had the same problem and it happened around the time of the Roku 9.3 update, so I'd been searching for answers related to that.  Some users experienced guide-related problems with the update, so it seemed a reasonable culprit.

I changed to a zip code directly across the river from me and the guide populated (no system restart required).   For what it's worth, he river isn't that wide but the side I live on is rural and the side I changed to is quite metro.

Thanks again for sharing!

Rick

0 Kudos
madizzy
Level 8

Channel guide does not work anymore live tv

1 month ago I had no problem getting the channel guide in live tv mode. Simply pressing the left arrow button on the remote wheel would call up the channel guide. Now every channeled says No Data Available. I've tried everything , unplugging it, rescanning it etc. Why did it decide to do this now?? Can you please fix this? 

ISK8TOOFAST
Level 7

Re: Channel guide does not work anymore live tv

I'm having the same problem for the past week or two

0 Kudos
madizzy
Level 8

Re: Channel guide does not work anymore live tv

And nobodies helping with this. What good is Roku tv if you can't see what you want to watch? 

RokuDanny-R
Roku Employee
Roku Employee

Re: Channel guide stopped working - "No Data Available"

Hi everyone,

Thanks for the posts.

Customer have reported that they were able to resolve the issue after performing a factory reset. For more information about how to perform a factory reset visit our Support page here: How do I factory reset my Roku® streaming device?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
Tags (2)
0 Kudos
reeder212
Level 7

Re: Channel guide does not work anymore live tv

Im having the same problem

 

0 Kudos
reeder212
Level 7

Re: Channel guide does not work anymore live tv

Exactly my point too! What is the purpose of channel guide if it is only going to say NO DATA AVAILABLE and cannot get help anywhere with this issue