Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MattyKingKilla
Level 7

Apple AirPlay Won’t Connect to TCL

Apple AirPlay not working

Hi. I purchased at TCL 65R615-CA in November 2019 and in the last month or so I’ve tried using AirPlay for the first time and it hasn’t worked. I have up to date Roku OS (10.0) and iOS (14.7). I’ve tried with two different iPhones and same issue. I don’t have another Roku device to try to troubleshoot that way.

I’ve called tech support and they have no solutions. I’ve factory reset, power cycled, enable fast start on the TV, a system restart, and made sure all settings are on that need to be on both Roku and iOS with no success. All devices are on the same private home network. The iPhone can talk to the TV because I can set it up in the Home App to turn on and off.

When I try to AirPlay (from browsers or apps) it’ll either do nothing or bring the AirPlay settings screen up.

Any help or insight would be appreciated.

0 Kudos
1 REPLY 1\
StreamerUser
Community Streaming Expert

Re: Apple AirPlay Won’t Connect to TCL

This appears to be a recurring issue with the AirPlay2 support.

1) Verify you have the latest AirPlay support:
     A) Using remote: Home 3x, Up 2x, L, R, L, R, L (AirPlay should be 1.14-104 or later)
     B) Settings/System/System update/Check now (should be 10.0.0-4209 or later) - try again

2) Verify your devices arent connected to a Guest SSID or otherwise have AP/Client Isolation enabled on the SSID - try again

3) Disable & re-enable WiFi on the Apple devices - try again

4) Restart all devices (Rokus, Apples, modem/router/gateway) - try again

5) Reset the paired devices: Settings/Apple Airplay and HomeKit/Require Code/Reset Paired Devices - try again

6) Setup HomeKit: Settings/Apple Airplay and HomeKit/Setup HomeKit - try again

7) Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz - try again

8) Manually configure Roku's display output to 1080p: Settings/Display type/1080p TV - try again

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos