Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DuelingFatty
Level 7

After some use, disconnects from wifi and gets stuck in wireless scan

I have a new Roku Express 4k(about a month old). Every so often it will randomly disconnect from my WIFI. When you go to look for WIFI my SSID isn't in the list. I know my wifi is working as my tablet, phone and laptop are still connected and working. When I go to scan for wireless it just loops and you can't exit out. You have to do a soft/hard reboot.

 

I've read from support staff that the Roku will only connect to 2.4Ghz but that's not the case as seen in the screen below. 

Other info is TPLink Archer A7 router.

Any help is needed outside of resetting wireless and the Roku.

 

 

 

Screenshot_20211017-115727.png

 

0 Kudos
1 REPLY 1
AvsGunnar
Community Streaming Expert

Re: After some use, disconnects from wifi and gets stuck in wireless scan

@DuelingFatty 

The Roku Express is only capable of operating on 2.4ghz.  The new Roku Express 4k/4k+ devices (like yours) is dual band so able to operate on either the 2.4ghz or 5ghz.

If you find that you keep losing connection on the 5ghz band, you can try using the 2.4ghz band which may give you a better/more stable connection or alternatively, instead of using "Auto" channel selection on the 5ghz, try manually assigning a channel using 36-48, or 149-161.  Whenever Auto wireless channel is left enabled on the 5ghz band, there exists the possibility that the router will select a non-compatible (DFS channels 52-140) that will cause the Roku to disconnect and be unable to reconnect.  Roku cannot see/use these DFS channels.  Could also be just some noise/interference on this 5ghz band that the Roku is having problems with, again causing disconnection.

For your router, you should be able to make the channel change under the Advanced tab...Wireless..Wireless Settings..5ghz..

You will have to disable "Smart Connection" first if you wish to assign manual channels on the Archer A7.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos