Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
TheyWantPeach
Level 7

APPS LAUNCHING BUT NOT PLAYING VIDEO on Roku TV

I have a ROKU smart tv, now the screen is fine when I turn it on, I’m able to go into apps (Hulu, Netflix, and Disney+) but when I click something I want to watch the screen is blank. The audio and subtitles for the show are playing but the screen is blank. I even tested it with Hulu, I heard every commercial but the screen was black. When I exit the show, I can see my Hulu screen (you know where I pick what to watch) but as soon as I select something the screen is all black and I’m just listening to shows 

5 REPLIES 5\
RokuDanny-R
Roku Employee
Roku Employee

Re: APPS LAUNCHING BUT NOT PLAYING VIDEO

@TheyWantPeach 

Thanks for the post.

We would first recommend removing a channel that you are experiencing the issue on. Then restart your TV and add the channel back again to see if you are still experiencing the issue.

If the issue is still not resolved, please contact your TV's manufacturer directly to report this issue and request additional support. Each Roku TV manufacturer provides direct support and warranty services for their products running the Roku OS. 

For a list of Roku TV manufacturer contact information, visit our Community post here: Contacting Support for Your Roku TV


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Uzzy1951
Level 7

Re: APPS LAUNCHING BUT NOT PLAYING VIDEO

I have the same issue with my Roku premiere.... apps launch but will not play. None of them will.

b_willy67
Level 7

Re: APPS LAUNCHING BUT NOT PLAYING VIDEO

We have a TCL TV and had this issue. We went into settings/system/power/ and then hit system restart and it worked again.

ChasWms
Level 8

Re: APPS LAUNCHING BUT NOT PLAYING VIDEO on Roku TV

I've had a similar problem twice in September 2020 with my TCL Roku TV. The first time, I had a black screen and no audio from my cable STB (HDMI) & simultaneously no video or audio (but menus were fine) in my cable provider's app. A few TV reboots seemed to correct it. The 2nd time, a couple of weeks later, audio & video were missing from the STB and all apps. A couple of reboots restored audio, and a few more restored video as well. Huh??

@https://community.roku.com/t5/Playback-Issues-Audio-Video-Power/Video-play-back-not-working-in-apps-...

@https://www.reddit.com/r/techsupport/comments/hilgvs/tcl_roku_tv_playing_audio_but_no_video/

0 Kudos
MkCearlock
Level 7

Re: APPS LAUNCHING BUT NOT PLAYING VIDEO on Roku TV

I had the same problem. Video would not play when streaming, only sound. I was able to turn the tv off and unplug from the electrical outlet for a couple minutes, plug back in and it started playing. It's like doing a cold boot on your computer instead just a restart. 

0 Kudos