Community Discussions

Connect with other Roku users to learn more about streaming, cord-cutting, finding your favorite content, or talk about the latest entertainment happenings. It's all on Roku!
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Roku ultra audio does not play for first 2-3 seconds of any app or channel

I recently bought a 2020 Ultra to replace an older Ultra, and I'm running the audio only through an ancient Denon AVR receiver (no HDMI). The media player in particular is maddening; the Roku will not play the first 2-3 seconds of any song and is completely fine after that.

2 troubleshooting notes;

-I've gone into audio settings and tried every single audio setting (pcm, Dolby digital, dts, etc.) and have the same exact problem on each setting. No setting seems slower or quicker on launch than any other.

-It's not the receiver. When I connect the external hard drive to the TV itself I can hear the opening notes of every single song on the drive. I use the TV as an audio switcher and do not run any video into receiver. The same external hard drive only has this opening hiccup through the Ultra and nothing else.

Conventional troubleshooting says to try every audio setting in the Roku menu. Been there, done that and there's no setting that makes the audio play right away, but all the Android TV apps and the PS4 also connected to the TV have no problems playing the opening notes. It's definitely the Roku.

Help!  Thanks in advance!

0 Kudos