Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Streaming Star

streaming channels section not loading

I own a Sceptre TV. When I bought this in October and connected my Roku Ultra, everything worked great. Now, for the last 2 months or so, the Streaming Channels section doesn't work. I'm talking about the entire section. Click it on to browse, only loads about half the channels. Try to install one, only works about half the time. Sometimes it installs and the tile is blank. Try to remove it, needs a few tries. I plugged in my old Roku 3 and it's doing the same thing. Even tried a factory reset on that one. Tried new hdmi cords, wireless and wired connection, reset the TV, different hdmi plugs, whatever else I can think of. Firestick works great, so does the blu-ray. Is this a firmware problem or what? I'm tired of browsing for channels on the laptop, then going to the search section to find and install what I've found. Once channels are installed, they work great. A few of them have a random black screen for a few seconds issue (mostly the locals), but most are OK. Is ANYONE out there having this problem?

0 Kudos
Community Streaming Expert

Re: streaming channels section not loading

This sounds to me like a network connectivity problem.

This has always worked for me to re-establish my net connection when it has been lost or not performing well:

  • Restart the router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • Restart the Roku to clear its memory. Depending on your Roku model and Roku version number you'll find the System restart option under either Settings > System or Settings > System > Power. Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings > Network > Set up connection.

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.


Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos