Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Channel Surfer

Re: Disney Plus not working - Error Code 42

you figured it out.

their little update isn’t escaping past the lan dns. 
I do have a pihole but it’s been disabled for a while. However, every other device, application, etc is smart enough to look outside the lan dns so it’s never been a problem. 
I deleted the lan dns and Disney+ works. 
I’m not saying Disney+ did this specifically to nuke piholes. They don’t serve ads. What they did do was pretty boneheaded though as I’ve never seen it be a problem anywhere else. 

roku and Disney y’all need to give the users who figured out it was a dns problem and mnye01 here a free year of Disney+. 
im not talking about myself. I knew it was dns  related but was overlooking my LAN. 


Thank you mnye01. If you’re ever in Biloxi, MS I owe you a beverage. 

Roku Guru

Re: Disney Plus not working - Error Code 42

It wouldn't be disney that did it. The app works fine rolling back to roku 10.0, same app version. I've verified this personally. The problem occurs when roku updates. Roku is an advertising company. Roku did it, perhaps unintentionally but they stand to gain trying to mess with ads. Despite the fact I pay for the ad free tiers on my programs personally, and pihole not really blocking most video ads. They are probably messing with dns and pihole related stuff, Disney just a casualty. Either way, I'm done with roku. I'll get my tv on a firmware where everything properly works, pull it off the internet and start streaming with Amazon. Something I've gone with roku for years to avoid. But seriously, I'm done

Roku Guru

Re: Disney Plus not working - Error Code 42

For those that are only here because of Disney, other apps broke, the TV tuner broke etc on 10.5. Definitely not saying it's disney. It's absolutely roku that caused this. I spent an entire day troubleshooting, rolling back my tv version etc. Don't ask about rolling back, it only lasts a day or two before it updates again back to broken. 

Channel Surfer

Re: Disney Plus not working - Error Code 42

pihole user here, too. Well, kind of..


The rasp pi I had running pihole was dead but it was my first DNS server (followed by and prior to my Disney+ troubleshooting.  I didn't mention that in my previous post because it was dead and so I (mistakenly) assumed it wasn't relevant.  


I'd have my pihole back up and running if I could find any reasonably-priced pi 3 Bs around. 

Roku Guru

Re: Disney Plus not working - Error Code 42

Understood, So it isn't pihole specifically. It sounds like roku isn't picking up the need to switch to a secondary dns. And of course you can't just manually set a normal dns on the TV to just WATCH STUFF. I can't justify changing my entire network setup for a change on roku end, dear support team. We are narrowing down the actual problem here for you. I'm begging you, relay the info. DNS something, somewhere changed in the firmware pipeline. 


My problem is no doubt related but not quite this scenario. Thank you for the info. Get an old pi1 or one of the little zero sticks used or wherever you can. Pihole needs nothing in terms of specs. Mine runs on a zero w or whatever it is and have used a 1 for it. Always good to throw old ones in a box when possible so I have a few.


Hopefully support team (yo Danny) are seeing this and relaying the info to engineers. It's not those 4 or 5 poor people fault but this absolutely needs to be addressed. It's not us that made them take the brunt of this on the front line, Roku did that to them. Seems like a REALLY small company despite being worth billions. Point them at DNS protocols Danny, please for the love of God. 


Re: Disney Plus not working - Error Code 42

Confirming what Musoka reported.

The current version of the Disney Plus app on Roku fails to failover to a second DNS resolver if the first is unreachable. This results in Error Code 42 ("trouble connecting").

Other services (ex. Netflix, Prime Video, etc.) continue working in the same scenario.

This issue is not specific to Pi-hole users, but this group is more likely than average to have an unreachable DNS server.

To fix, affected users should ensure their first DNS server is reachable.

To check if your first DNS server is reachable, open a command prompt on a Windows computer, run ipconfig /all to find your DNS servers, and then run nslookup $InsertIPofYourFirstDNSServer to verify that it is reachable. If you see "DNS request timed out" in response, then that DNS server is failing.

0 Kudos
Channel Surfer

Re: Disney+ not working - Error Code 42

Model: 3810X - Roku Streaming Stick+

Serial number: YH009M192910

software Version: 10.5.0 build 4201-50

timestamp: 2021-12-05T21:50:10Z

ID.  10-488-30

disney+ error 42 after clicking on the app. All other apps work. Doesn’t work on all 5 ROKU sticks I have.

0 Kudos
Reel Rookie

Re: Disney+ not working - Error Code 42

I had an older Roku Device (3800 I think) and like many Disney+ was erroring with 42 as of about 2 months ago.  So thinking maybe it was the older Roku, we bought a replacement 3810RW streaming stick.  Installed and configure today and everything works...wait for it...except Disney+ with a Error 42.  And I read this whole thread about some of the things people did to fix ... I use Open DNS service and and not the or (Google's).  I have many devices and TV's (large family), Phillip's, Visio, Sony, Amazon/Fire and fire stick, and PC/Tablets all able to run Disney+ with no problems.  This 3810 RW reported that my connection to the stick was 49Mb and I have 1.2gb service so its not a bandwidth issue.  So Roku, you need to address all these users with the Error 42 with Disney+ and figure out what is the problem.  I am most likely going to return the new Roku Device and buy something else so that my son can watch Disney shows.  It is ridiculous that there has been no acknowledgement of a problem other than asking to provide the support info from your device.  With this many reports of issues, its not a DNS problem or connection issue.

Reel Rookie

Re: Disney+ not working - Error Code 42

I want to thank you all for the info on this thread, I was able to fix my Error Code 42 with Disney+ (and ESPN and Hulu).  It was DNS (why is it always DNS) or the failure of the Ruku+Disney to fall back to secondary DNS provider listed.

My problems started about 2.5 weeks ago.  Disney+ (and ESPN+/HULU) stopped working on my Roku Ultra and Roku Ultra LT boxes (both using wired connections not WIFI).  Other streaming service on the Roku worked, and Disney+ worked fine on a Smart Samsung TV, tablets, computers.

Tried remove, reboot, add, cycle router, cycle power, repeat, repeat, and repeat with no success.

Finally found this thread and took a look at the DNS settings.  On the network that the Roku boxes were connected to the first DNS IP listed was in error and pointed to a non-existent local DNS server, the secondary and third listed were Google and ISP DNS IPs.  I changed the 1st DNS server listed in the DHCP settings for the network to and rebooted the Roku.  Disney+ immediately started working.

At least in my case it's clear that Roku+Disney (and ESPN/Hulu) are unable to fall back to the secondary DNS provider listed in a network.  Someone needs to fix their DNS code.

Reel Rookie


Changing the DNS did work for me.

Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.