Channels & viewing

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Disney Plus protected content error

I have the Roku Ultra. I keep getting the “Error cannot play protected content” for several months now and have done everything I have found to do to try to troubleshoot this issue. There are days when it works fine but today with every episode I watch I get the error and have to back out of the app and turn my TV & Roku off and back on in order to get it to play. Is there anything else that can be done to prevent this from happening? Here is a list of things I have done:

1. Reset Roku through settings (several times)

2. Deleted app, reset Roku, reinstalled app

3. purchased a new HDMI cord 

4. swapped spots on the TV with HDMI cord 

Those are all the steps I have found to do between here and Reddit and other places. It is getting very aggravating to reset the device and have to sign into all of the different accounts I have. I really hope someone can help!! 

Labels (1)
Level 20

Re: Disney+ protected content error

You didnt state which Roku Ultra model you have (the 2020 Ultra is the 4800), your firmware version, or your Disney+ app version, and it also isnt clear what you mean by "reset":

Do you mean "Restart"? (Settings/System/System restart)

or "Network Connection Reset"? (Settings/System/Advanced system settings/Network connection reset)

or "Factory Reset"? (Settings/System/Advanced system settings/Factory reset).


1) Some people have reported simply restarting fixes the issue.

2) Others have reported network connection reset fixes the issue.

3) And yet others have reported a factory reset fixes the issue.

If you havent done the above 3, in order, you should - otherwise there are a couple of other things to try/check as well on your Ultra:

1) Disable Auto adjust display refresh rate: Settings/System/Advanced system settings/Advanced display settings

2) Manually configure your Display:  Settings/Display/choose a resolution

Additionally, non-Roku fixes include:

1) Check/update your (unknown brand/model) TV's firmware

2) Restart/reboot all networking equipment (modem/router/gateway)


0 Kudos

Re: Disney+ protected content error

Hi there! Model is 4662RW, Software version is 9.4.0 build 4200-46, Disney+ app version 1.11 build 2021021200. I did all three of those steps in order at least three times over the past couple of months! And let me tell you it’s aggravating!! Lol! I did however just check and saw that my Display refresh rate is not on auto and my screen resolution is now set at 1080p. Hoping those little things help! I promise I’ve tried troubleshooting as much as I can in order to be as proactive as possible and not bother anyone! I will look into this further if I still have problems. Thanks again! 

0 Kudos
Level 20

Re: Disney+ protected content error

If Settings/Display is set to "auto detect", manually select something else (do not leave it at auto detect).

Try restarting all of your network equipment (modem/router/gateway), and check to see if there is an updated firmware version for your TV.

For some non-Roku platforms that get this error, disabling IPv6 works (either in the device or in the modem/router/gateway)

Its also worth reporting it to directly to Disney+ (its their app):

0 Kudos
Level 7

Re: Disney+ protected content error

This is infuriatingly frustrating.  A brand new Roku TV (onn. model) and it was playing Disney+ just fine.  Now I'm getting this error.  I've reset network settings.  Factory reset the device.  Still the error persists.  Is this a Roku issue or Disney+ issue?

0 Kudos
Level 20

Re: Disney+ protected content error


You didnt mention your Roku model # or firmware version (Settings/System/About) or app version (highlight the app and press Options (*) on the remote).

Though you tried the Network Connection Reset and Factory Reset, If you haven't already reinstalled Disney+:

1) Remove the app (Highlight the app, press the Options (*) button on the remote, then Remove)

2) RESTART the Roku (Settings/System/Power/System restart/Restart) <-- MUST DO THIS HERE!!!

3) Re-install the app

(If you dont restart after removal, settings/cached data associated with the app are left behind and it wont be a clean re-install)

You can also try disabling framerate matching:  Settings/System/Advanced system settings/Advanced display settings/Auto adjust display refresh rate=disabled

Otherwise, Disney codes the Disney+ app, and you'll need to contact them:

0 Kudos