Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot view Philo on Roku 3930

I too cannot view Philo just as of today, Tue. 12.7.21.

I have 3 Rokus & it just happened today on my newest Roku device model: 3930x

S/N:  S009311A8VUP

If it's an update issue, which makes perfect sense, I don't understand  why only one ofRoku devices affected.

Tags (1)
0 Kudos
Streaming Star

Philo Not Loading on my sticks.

I see the "problem resolved" message when I enter this website but #Philo is still not loading for me. If I try going into Philo the screen either sticks to the opening Philo screen or goes black and does nothing else. I know you're aware of service issues but I am just now able to access this website. I cannot remove Philo and re-download either. I just tried and the option to remove is not there when I press the star button. I am using a 3810RW streaming stick that I've had for maybe 6 months. No problems with it until your shutdown this morning. Is this still being worked on or how do I fix it

0 Kudos
Retired Moderator

Re: Cannot view Philo on Roku 3930

@SuzeQ21 @huntmarv 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing? Please keep us posted what you find out.


Danny R.
Roku Community Moderator
0 Kudos
Reel Rookie

Re: Cannot view Philo on Roku 3930

I just got off the phone with  Philo support and it looks like they're app needs to be updated since Roku just did an update. They should be working on it shortly.

Update- if you go to all showing and then click on the box that says "live"  and press & hold the OK  button, it'll start playing.

0 Kudos