Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Binge Watcher

Cannot remove corrupted CWTV app

Two devices. 1) Roku Premiere+ (4630 series)   running 11.5.0 build 4196 update today [09.27.2022]
                      2) Roku Ultra (4800 series) OS Version? It died before I could look it up.

I currently have an issue with THE CW TV app in Roku.  If I try to open the CW App the Roku device reboots in the FACTORY RESET condition. No other app does this. After re-configuring the factory reset device THE CW app is automatically restored from the Store.  I try to manually remove the app but when I press the menu button * the device crashes and restarts again in the Factory Reset state.  I do not even get to see the menu that lists the app version or the options to rate, move, remove, or check for updates.

I have already discovered that you CANNOT remove a channel from your account or device using the ROKU website's channel store.  You are only allowed to add a channel and see which channels are currently installed.

So I fear that the 4630 was no longer supported and unfortunately purchased a new Roku Ultra (4800 series) because it's the only device with Ethernet. Why? ROKU does not support Certificate Based Radius authentication for WLan.

I setup the Ultra, found that the store restored THE CW app to my new device.  I tried the app to see if it worked. (This was definitely a mistake.)  The Ultra instantly crashed.  Now the device will not start. The white light on the front of the device just continues to blink non-stop. PUSHED and HELD the reset button, no change.  I'm taking the device back to the store tomorrow.

***NOTE***  I realize this next part is completely irrelevant to Roku, but it will add perspective to the problem I having with the CW app on ROKU.  I turned to my Android mobile device to use the CW app only to find the app was missing. I tried to reinstall the app but was immediately greeted with "This application has been prohibited by your mobile provider."  Not a good sign.  Now I turn to a PC to visit the CWTV.COM website, but all I am getting is ''s server IP address could not be found.'   This leads me to believe there are far bigger problems with THE CW than just a malfunctioning app.

Again how do I get rid of this app from my ROKU devices?

0 Kudos
Roku Guru

Re: Cannot remove corrupted CWTV app


A few things:

1)  Seems like firmware version 11.5.0-4196 is very unstable/buggy with the 4630 - have you tried opening/using the Options (*) button with other apps?  Do other apps crash when opened/Option'ed?

2) If your internet connection is your mobile provider (as in, you are using a mobile router/gateway device for internet access), and they are blocking access to CW-related DNS/IP, that could explain most of the behavior of all devices (aside from the Roku Factory Reset).  Do you have an alternate means of internet access that you can test with the Roku/CW app?

3)  Next time the 4630 Factory Resets, or if it is accessible now, make sure you check for updates multiple times (until it doesnt find any):  Settings/System/Software Updates/Check now

Tagging @RokuDanny-R  in regards to OS 11.5 issues.

0 Kudos
Retired Moderator

Re: Cannot remove corrupted CWTV app


Thanks for the post.

We would be more than happy to investigate the issue further for you. Can you please provide us the following information:
-Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel (this can be found be selecting the channel on the Home screen and pressing the * button)
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times and provide us with this ID)
-steps to reproduce the issue you are seeing 

Once we have this information, we will be able to pass it along to the appropriate Roku team to investigate further.


Danny R.
Roku Community Moderator
0 Kudos
Binge Watcher

Re: Cannot remove corrupted CWTV app

I personally used to have this same issue with the CW app constantly causing the device to crash.  At one point I was directed by CWTV support to remove the channel, restart the device, then reinstall. (I was going to provide a link to the support article, but that URL is no longer valid/missing.)  I then found myself with the same problem that you cannot remove the channel because the Channel Info page(pressing the * button) could not be opened, but I did not experience the Factory Reset issue you described. Just like you I found that when I manually performed a factory reset the CW app was automatically restored during the initial setup process preventing me from removing the channel.  

After several weeks of working with support there was only one solution.

Create a new ROKU account.

My personal advice is that once you create a new account avoid the CW Channel at all costs. 
Then another personal opinion is that if you wish to watch CW content at the present time I strongly urge you only do that using Over-The-Air(OTA), Cable, or Satellite services.

Once you have your device running again under a new Roku account it would be prudent you use the Roku website to access the OLD account to cancel all active subscriptions, remove any payment methods stored in the acct, then Deactivate(Delete) the account to prevent the CW app from being automatically restored to any other linked devices.

Roku Express+ (3710 series)  

Reel Rookie

Re: Cannot remove corrupted CWTV app

Hello @UserOfStreamers

This is my new account.  I ended up following what @DingleBob3899 suggested.
Not only did it solve the problem, it also solved a second problem from 2017 that I had forgotten about.

No. i have no intention of trying the CW app ever again.

However, I wanted to follow up on your questions for the Roku Premiere+ (4630 series) .

1)No other app displayed this behavior only the CW app. Once I changed accounts all problems disappeared.

2)I normally use my high speed fiber connection, but I did try Verizon, T-Mobile, Spectrum, and CenturyLink for troubleshooting. All had the same results. I tried using several other DNS servers as well with no change. (CloudFlare, GoogleDNS, Quad9, Level3, OpenDNS)

3) I forced the device to check for updates at least 10 times. Nothing newer than 11.5.0-4196

I mentioned a second problem from a few years ago that creating a new account also resolved.
I still have a Roku HD (2500 series)  that stopped functioning.  After a hard reset I tried to setup it up again using my previous account to see if it was a firmware or app problem.  The device would crash and restart when I tried to open ANY channel.  I could search for channels and add/delete them, but couldn't open any of them without the device crashing.  I did a manual factory reset.  I used my new account for the initial setup this time.  It successfully downloaded and installed Ver 9.1.0-5009, installed all the channels that I currently have on the 4630 and is functioning as expected.  The menus are kind of slow to respond, but the playback quality seems perfectly fine even while tethered to a mobile phone for internet connection.  (Roku wifi is not compatible with my home WLAN)
It's really curious the device I thought was no longer useable works perfectly fine after switching to a new Roku account.   I went back and deleted the previous corrupted account.

Thank you @DingleBob3899 

0 Kudos
Roku Guru

Re: Cannot remove corrupted CWTV app


Glad you were able to resolve this with the experience knowledge of @DingleBob3899 along with reviving an older model, and thanks for the feedback response to my previous post.

Roku does have quirky account management with all sorts of limitations and problems (e.g. apps are account-linked, not device-linked, or e.g. apps can be added from the device or web/Channelstore, but can only be removed/deleted via the device, even though apps are account-linked not device-linked), and it sounds like some sort of corruption happened with the app linking within your account.

Even though its moot since you deleted the old account, @RokuDanny-R may have been able to resolve the account corruption with the help of the account engineering team, but considering how slow Roku is in general to resolve such things I certainly understand moving to a new uncorrupted account. 

The fact that your device did a Factory Reset every time you Option'ed the CW app doesnt bode well for the stability of 11.5 - hopefully @RokuDanny-R  forwarded this issue to the OS engineering team.

Reviving the usage of an older assumed-dead device through linking to a new account makes you wonder how widespread account corruption problems are (especially for older accounts) and exposes the flaws in the account-linked app system and other aspects of their account management.

0 Kudos