Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
topchat
Reel Rookie

All4 app not working and displays All4-009 code

All of a sudden the Channel 4 app, All4, does not run. The message displayed is -

Well this is embarrassing.
Something's not working. Please try again in a few minutes.
All4-009


Have reported to Channel 4 customer support but have not had a response as yet. And, yes, I’ve deleted and reinstalled the app so at the latest version , as is the Roku software on my Streaming Stick 4K. Other apps, such as BBC iPlayer, are working. 

Any ideas!

0 Kudos
4 REPLIES 4
Boz
Roku Guru

Re: All4 app not working and displays All4-009 code

0 Kudos
makaiguy
Community Streaming Expert

Re: All4 app not working and displays All4-009 code

After removing a channel, best practice is to restart your Roku to clear its memory cache before reinstalling the channel. Without the restart you may not get a clean reinstall.

Depending on your Roku model and Roku version number you'll find the System restart option under either Settings > System > Power or under Settings > System.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Ultra 4800 | Streaming Stick 4K+ 3821 | TCL Roku TV 43S245/C107X
0 Kudos
DaveKnight
Newbie

Re: All4 app not working and displays All4-009 code

I have also had this problem fir some time now. I have tried all of the suggested solutions but nothing works. I have literally just finished setting up a brand new out of the box 4K streaming stick and it has exactly the same error. The all4 app native to the TV works fine but just not on the Roku. It did work for a couple of weeks on my first Roku but then just stopped one day and hasn’t worked since. 

My only thought is perhaps it has something to do with my Truespeed fibre connection not being recognised properly.. Do you have full fibre? 

0 Kudos
topchat
Reel Rookie

Re: All4 app not working and displays All4-009 code

As it happens we have full fibre, FTTH, and this predates getting a Roku stick. Not sure how this impacts just the All4 app, as other apps work just fine. I understand that the Roku 009 error code relates to a broadband issue but this clearly doesn’t apply in this case as other apps stream as expected. 

I’m fairly sure that this problem emerged when version 5, build 9, of the All4 app was released. But there is some comment it started with earlier versions, although not with the same error message. Might have to chase Channel 4 again for a response.  

 

0 Kudos