Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
ldr223
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

Hi, Here is a update I still can't get it to work at all plus I don't know how to download Apache. I wanted to know if there any web server beside Mongoose or Apache that anybody download as a web server. I took roksbox off and added back on too.
0 Kudos
midiwall
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"ldr223" wrote:
Hi, Here is a update I still can't get it to work at all plus I don't know how to download Apache. I wanted to know if there any web server beside Mongoose or Apache that anybody download as a web server. I took roksbox off and added back on too.

Installing and configuring Apache is not for the faint of heart... Please give us more info about what it means that you "can't get it to work".

Did you try the link that I pointed at? What about the one that WilDD pointed at?

Can you get to the web server from the machine that it's installed on? Validate that first before worrying about what Roksbox can see.

If you're deadset on trying Apache, it's here:
http://httpd.apache.org/download.cgi
:: Mark
0 Kudos
WetFactory
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

I'm trying to set up the Mongoose server according to the directions here but I'm having some trouble. The instructions posted do not match what I'm encountering.

Here are the steps I took in trying to install the server - I left no step out here. What you read is what I did. This is using Windows Vista Home Premium 32 bit.


1. Downloaded mongoose-2.11.exe from the Mongoose website
2. Located downloaded file, right clicked, selected "Run as administrator"
3. A small "m" icon appeared in the taskbar tray
4. Created folder called www located at c:\www
5. Right-clicked Mongoose icon in taskbar tray and selected "Edit Config File" (Mongoose wasn't listed in All Programs as was stated in online manual)
6. In config file, I found a line # document_root .
7. I deleted the hash mark replaced the period with c:\www
8. I rebooted the computer
9. Upon rebooting, the small "m" icon was gone from the taskbar tray
10. I went to http://localhost and got the standard "Unable to connect" error message
11. I create a small index.html file and place it in the same directory and tried again but got same error (not sure if this would have worked anyway)
11. I opened msconfig and looked under Services but Mongoose was not listed
12. I initiated the program again from the downloaded .exe file
13. The small "m" appeared again in the taskbar tray
14. I tried opening localhost again but got the same results


Here's what I see when I right-click the "m" icon in the taskbar tray:



Here's the contents of the config file before I made any changes:

# Mongoose web server configuration file.
# Lines starting with '#' and empty lines are ignored.
# For detailed description of every option, visit
# http://code.google.com/p/mongoose/wiki/MongooseManual

# cgi_extensions .cgi,.pl,.php
# cgi_environment <value>
# put_delete_passwords_file <value>
# cgi_interpreter <value>
# protect_uri <value>
# authentication_domain mydomain.com
# ssi_extensions .shtml,.shtm
# access_log_file <value>
# ssl_chain_file <value>
# enable_directory_listing yes
# error_log_file <value>
# global_passwords_file <value>
# index_files index.html,index.htm,index.cgi
# enable_keep_alive no
# access_control_list <value>
# max_request_size 16384
# extra_mime_types <value>
# listening_ports 8080
# document_root .
# ssl_certificate <value>
# num_threads 10
# run_as_user <value>


mongoose-2.11.exe is currently listed as an exception in my Firewall (Windows Firewall).

I've already ponied up the $10 to give this a fair shot so I'd like to be able to try it. I've already installed the channel into my lineup on the Roku box. Any help would be appreciated.
0 Kudos
midiwall
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WetFactory" wrote:
9. Upon rebooting, the small "m" icon was gone from the taskbar tray

Mongoose defaults to running as a console application. You'll want to find "Mongoose web server" in the Programs list, then use "Start As Service".

Here's the contents of the config file before I made any changes.
...
6. In config file, I found a line # document_root .
7. I deleted the hash mark replaced the period with c:\www
If that's all you did, you need more - you also need to define the ports that it should be listening on. This is my config file:
root            d:\shares\
ssl_cert C:\winapps\mongoose-2.8\ssl_cert.pem
ports 81,444s
access_log c:\mongoose_access_log.txt
error_log c:\mongoose_error_log.txt

For you, the PORTs line would more likely look like this:
ports           80,443s

Also, set those _log lines and see if Mongoose logs anything when you try to access the server.
:: Mark
0 Kudos
WetFactory
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

Thanks - I modified the port line in the config file to read as follows:

# Mongoose web server configuration file.
# Lines starting with '#' and empty lines are ignored.
# For detailed description of every option, visit
# http://code.google.com/p/mongoose/wiki/MongooseManual

# cgi_extensions .cgi,.pl,.php
# cgi_environment <value>
# put_delete_passwords_file <value>
# cgi_interpreter <value>
# protect_uri <value>
# authentication_domain http://localhost
# ssi_extensions .shtml,.shtm
access_log_file c:\www\mongoose_access_log.txt
# ssl_chain_file <value>
# enable_directory_listing yes
error_log_file c:\www\mongoose_error_log.txt
# global_passwords_file <value>
index_files index.html,index.htm,index.cgi
# enable_keep_alive no
# access_control_list <value>
# max_request_size 16384
# extra_mime_types <value>
listening_ports 80
document_root c:\www
# ssl_certificate <value>
# num_threads 10
# run_as_user <value>


This time when I went to localhost it actually displayed the contents of the test html file I placed in the directory. I deleted the html file, refreshed, and found the contents of the www directory.

But the program still isn't listed in my "Program Files" or anywhere else I can find other than the www folder and the taskbar tray. I cannot find a way to start it as a service.
0 Kudos
midiwall
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WetFactory" wrote:
Thanks - I modified the port line in the config file to read as follows:
...
This time when I went to localhost it actually displayed the contents of the test html file I placed in the directory. I deleted the html file, refreshed, and found the contents of the www directory.

Whoop-Whoop! Smiley Happy

But the program still isn't listed in my "Program Files" or anywhere else I can find other than the www folder and the taskbar tray. I cannot find a way to start it as a service.

Hmm, looking back at your first post, the pop-up you saw when you right-clicked on the icon actually shows that the service is installed. I wonder if things look different on Vista home in terms of services? Try this..
  • Start button

  • enter "services.msc" (no quotes) into the dialog box

  • hit enter

Do you get the "Services" app? if so, look for "Mongoose 2.8" and see if it's set to "Automatic". If it is, n/m, you're all set, if it's not, double click set it as such (drop-down list) and then "OK" out of the dialog.

If for some reason you can't set the service, then you can always create a shortcut to Mongoose and drop it in your Startup folder.
:: Mark
0 Kudos
WetFactory
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

Thanks - I seem to be in much better shape now. I was able to get the service started using services.msc

It's late though and I'm going to have to put the rest of the process on hold for the night. I've been at this for a while now Smiley Happy

Thanks again for the help. I'll let you know if I run into any additional snags.
0 Kudos
midiwall
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WetFactory" wrote:
Thanks - I seem to be in much better shape now. I was able to get the service started using services.msc

It's late though and I'm going to have to put the rest of the process on hold for the night. I've been at this for a while now Smiley Happy

Thanks again for the help. I'll let you know if I run into any additional snags.

Awesome - good luck! (and you're welcome!)
:: Mark
0 Kudos
WilDD
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

For those having problems installing Mongoose:

There is a new version of Mongoose - V 2.11, which seems to have a different install procedure. I have changed the link on the Roksbox page that uses a previous version - V 2.8, which is known to work well. Follow the instructions at http://roksbox.com/home/index.php?option=com_content&view=article&id=53 to use this version until I get new instructions for the new version.
0 Kudos
WetFactory
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WilDD" wrote:
For those having problems installing Mongoose:

There is a new version of Mongoose - V 2.11, which seems to have a different install procedure. I have changed the link on the Roksbox page that uses a previous version - V 2.8, which is known to work well. Follow the instructions at http://roksbox.com/home/index.php?option=com_content&view=article&id=53 to use this version until I get new instructions for the new version.


Thanks for this. I've uninstalled v2.11 and have begun again using 2.8. So far it's working better but the day is still young Smiley Happy
0 Kudos