Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

"ironmb" wrote:
Hi, I tested this last night and it looks good. I was able to set it up to use my NAS, without installing any web server on my home PC. I tested it with "Pigeon Impossible" mp4, and it worked fine. But other mp4 files from Handbrake did not play. They would start, but immediately return to to the summary screen. So when I click to play, I get a brief black screen, then back to the summary. Anything special I need to select in Handbrake?


Start by setting the Average Bitrate to 1500 on the Video tab, and experiment from there to see what kind of quality you can get.

philsoft made this suggestion on another thread:

Videos must be encoded to fairly exact standards
try 720x480 mp4
1500kbs video
44100 audio at 192kbsphilsoft
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

I'm having a little trouble too.

I load the Roksbox channel. I have the XML file in the Videos folder only, that's all i'm trying to play. When I go to "My Videos", the Roksbox logo says on the screen for a long time. I keep getting the "XML file is not properly structured" or something similar to that (Roku is not in front of me right now).

When I go to the Music or Photos area, where there is no XML file, I get the error message much quicker, which leads me to believe it's reading the Videos XML file.

My IP is 192.168.1.2 (when i type this exactly into my browser, I get the root Media directory). I opened up port 80 on my router and even on Windows firewall.

I'm doing everything in the tutorial, no name changing when it comes to the folder names, etc. I'm using Mongoose and Handbrake. I went into Roksbox settings, and I do have the correct IP address as the server address.

I did reboot the computer after installing Mongoose, and I even did a CTRL-ALT-DEL, and saw that Mongoose is running in the background.

Any suggestions?
0 Kudos
Highlighted
Level 8

Re: Streamming Local Media Channel Available for Testing

"JC77" wrote:
I'm having a little trouble too.

I load the Roksbox channel. I have the XML file in the Videos folder only, that's all i'm trying to play. When I go to "My Videos", the Roksbox logo says on the screen for a long time. I keep getting the "XML file is not properly structured" or something similar to that (Roku is not in front of me right now).


I had the same issue at first. In my case it was antivirus software that was silently blocking mongoose from accessing the network.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

Hmm....I have to look into that. Which virus program are you using? I have MS Security Essentials.
0 Kudos
Highlighted
Level 8

Re: Streamming Local Media Channel Available for Testing

"JC77" wrote:
Hmm....I have to look into that. Which virus program are you using? I have MS Security Essentials.


I use "Charter Security Suite" free from my ISP.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

"JC77" wrote:
I'm having a little trouble too.

I load the Roksbox channel. I have the XML file in the Videos folder only, that's all i'm trying to play. When I go to "My Videos", the Roksbox logo says on the screen for a long time. I keep getting the "XML file is not properly structured" or something similar to that (Roku is not in front of me right now).

When I go to the Music or Photos area, where there is no XML file, I get the error message much quicker, which leads me to believe it's reading the Videos XML file.

My IP is 192.168.1.2 (when i type this exactly into my browser, I get the root Media directory). I opened up port 80 on my router and even on Windows firewall.

I'm doing everything in the tutorial, no name changing when it comes to the folder names, etc. I'm using Mongoose and Handbrake. I went into Roksbox settings, and I do have the correct IP address as the server address.

I did reboot the computer after installing Mongoose, and I even did a CTRL-ALT-DEL, and saw that Mongoose is running in the background.


IF you are talking about that black screen with the works "Roksbox" I have the same problem. But all I do is click left or right, then up and it goes out then it goes into the selection screen.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

thanks for you hard work on making this app works really well but i have one problem the artwork is not showing up for my movies i did everything like you said in the tutorial but it only asks me to pick the artwork once not twice like you said it did in the tutorial for the avatar trailer.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

"pjoshua5000" wrote:
"JC77" wrote:
IF you are talking about that black screen with the works "Roksbox" I have the same problem. But all I do is click left or right, then up and it goes out then it goes into the selection screen.


Yep, that's the screen. I'm going to have to try that out.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

"JC77" wrote:
I'm having a little trouble too.

I load the Roksbox channel. I have the XML file in the Videos folder only, that's all i'm trying to play. When I go to "My Videos", the Roksbox logo says on the screen for a long time. I keep getting the "XML file is not properly structured" or something similar to that (Roku is not in front of me right now).

When I go to the Music or Photos area, where there is no XML file, I get the error message much quicker, which leads me to believe it's reading the Videos XML file.

My IP is 192.168.1.2 (when i type this exactly into my browser, I get the root Media directory). I opened up port 80 on my router and even on Windows firewall.

I'm doing everything in the tutorial, no name changing when it comes to the folder names, etc. I'm using Mongoose and Handbrake. I went into Roksbox settings, and I do have the correct IP address as the server address.

I did reboot the computer after installing Mongoose, and I even did a CTRL-ALT-DEL, and saw that Mongoose is running in the background.

Any suggestions?


Usually when Roksbox hesitates for a long time after entering My Videos, it means that it is being block from your web server. If you have another computer on your network, enter your ip address into a web browser on that machine and see what happens. You can also temporarily turn you firewall off and try Roksbox. If it works, then you know your firewall is blocking it. You shouldn't need to open port 80 on your router, but you might need to allow http on your firewall.
0 Kudos
Highlighted
Level 7

Re: Streamming Local Media Channel Available for Testing

"JC77" wrote:
"pjoshua5000" wrote:
"JC77" wrote:
IF you are talking about that black screen with the works "Roksbox" I have the same problem. But all I do is click left or right, then up and it goes out then it goes into the selection screen.


Yep, that's the screen. I'm going to have to try that out.


This might clear the roksbox logo screen, but it really shouldn't have anything to do with making it work.
0 Kudos