Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
WilDD
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"haggie" wrote:
"WilDD" wrote:
Do you get the folder image, or does it say "Image not available"?


Neither. I get a grey image with a circle of dots in the middle for both the subcategory and the video itself. I've never seen a folder image before, but I have seen the "Image not available" image on instances where I had a poster path in the XML file but no image for it on the server yet.

One thought that comes to mind is that my literal path from the root is: Qweb->Videos. The web server path is http://10.0.1.5/Videos/. Could it be looking for a "Videos" directory on the root of the NAS rather than under "Qweb"?


According to what you have said, I believe your web root is Qweb, and you have a folder below that called Videos. If this is the case, your Roksbox setup should be:

Web Server Address: http://10.0.1.5
Media Root Folder: (blank)
Videos Folder Path: Videos

If your setup isn't like this, change it, then try again.
0 Kudos
farrelan
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WilDD" wrote:

According to the Roku SDK documentation, "FrameRate specifies the frames per second of the video. Valid values are 24 and 30." If you have a video with a different frame rate, try it and see what happens. It might work anyway.



I have also been trying to get 720p movies with 6ch to play with no luck. I was able to take these same movies an play them via usb. Seems the problem is only with streaming. I have been using Thumbgen to create movie sheets and nfo files for my movies. I re-encoded a movie to have 2ch audio and it seems to play just fine. This is gonna suck if I have to watch a HD movie in 2ch audio.

Is anyone else able to play 6ch audio movies at all??
0 Kudos
wdbames
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"farrelan" wrote:
"WilDD" wrote:

According to the Roku SDK documentation, "FrameRate specifies the frames per second of the video. Valid values are 24 and 30." If you have a video with a different frame rate, try it and see what happens. It might work anyway.



I have also been trying to get 720p movies with 6ch to play with no luck. I was able to take these same movies an play them via usb. Seems the problem is only with streaming. I have been using Thumbgen to create movie sheets and nfo files for my movies. I re-encoded a movie to have 2ch audio and it seems to play just fine. This is gonna suck if I have to watch a HD movie in 2ch audio.

Is anyone else able to play 6ch audio movies at all??


I use handbrake, which has the option to encode 6-channel audio into 2 using Pro Logic encoding. Then My Pro logic receiver decodes and plays the original 6-channel sound (at a somewhat reduced quality.)
This approach is not ideal, but it does work.
0 Kudos
farrelan
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"wdbames" wrote:

I use handbrake, which has the option to encode 6-channel audio into 2 using Pro Logic encoding. Then My Pro logic receiver decodes and plays the original 6-channel sound (at a somewhat reduced quality.)
This approach is not ideal, but it does work.


Yes i used handbreak to re-encode 1 movie just to run tests on. I purchased the XD|S because of the fact that it has hdmi and optical sound out. You would think that something with this kind of hardware would be able to support more than 2 channel sound. Im kinda at a wall here. I have mover 4TD of movies all encoded 720 or 1080 with 6ch audio and none play. To re-encode these would take months and at the same time loose my surround sound. Why even have the option to change the settings to Dolby Sound if you cant stream a movie with Dolby Sound to it.

I tried to turn debug on but got no output. No idea where its stopping at. Just sits there about half way through the loading. Is there no one that uses Roku stream or has tried to stream 6ch audio movies? Hard for me to believe I am the first and only one to have this problem.
0 Kudos
krisbee
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

It won't take months... it will take 10 minutes per movie (probably less), and you can put them in a batch mode.

It is just particular on what audio it needs. And, you don't have to lose the original audio, you can just add the 2 channel audio as well as setting the 6channel audio to what it needs to be.
0 Kudos
WilDD
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"farrelan" wrote:
"wdbames" wrote:

I use handbrake, which has the option to encode 6-channel audio into 2 using Pro Logic encoding. Then My Pro logic receiver decodes and plays the original 6-channel sound (at a somewhat reduced quality.)
This approach is not ideal, but it does work.


Yes i used handbreak to re-encode 1 movie just to run tests on. I purchased the XD|S because of the fact that it has hdmi and optical sound out. You would think that something with this kind of hardware would be able to support more than 2 channel sound. Im kinda at a wall here. I have mover 4TD of movies all encoded 720 or 1080 with 6ch audio and none play. To re-encode these would take months and at the same time loose my surround sound. Why even have the option to change the settings to Dolby Sound if you cant stream a movie with Dolby Sound to it.

I tried to turn debug on but got no output. No idea where its stopping at. Just sits there about half way through the loading. Is there no one that uses Roku stream or has tried to stream 6ch audio movies? Hard for me to believe I am the first and only one to have this problem.


HandBrake with AC3 Passthru has always worked for me with 6 channel audio.
0 Kudos
nakedbaby
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"WilDD" wrote:
According to the Roku SDK documentation, "FrameRate specifies the frames per second of the video. Valid values are 24 and 30." If you have a video with a different frame rate, try it and see what happens. It might work anyway.

Hmmm. I'll give it a go - just out of curiosity, do you speculate that Roku's SDK is oblivious to European video standards or do you think it is technically compatible but the writers of the SDK were ignorant of PAL? (Or just maybe too lazy to write about it?)
0 Kudos
nakedbaby
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"farrelan" wrote:
To re-encode these would take months and at the same time loose my surround sound.

Nah, it wouldn't be that bad. We have 1TB of video and it only took 1 night to batch re-encode the audio tracks for our videos. Then I used Subler to add the tracks back into the existing mp4's and presto we had working videos!
0 Kudos
WilDD
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

New version - V1.23.0

Two new features are available in this version.

1. Choosing category and subcategory display order when using a single XML file.

See http://roksbox.com/home/index.php?option=com_content&view=article&id=122


2. Displaying subcategory information in the information box with xml or nfo files when using the Grid screen.

See http://roksbox.com/home/index.php?option=com_content&view=article&id=123
0 Kudos
Gilgamesh
Level 8

Re: roksbox -Streaming Local Media Channel Available for Tes

"WilDD" wrote:
New version - V1.23.0
...
2. Displaying subcategory information in the information box with xml or nfo files when using the Grid screen.
...


Well, it's about time!!! :shock: Smiley Very Happy

Seriously, THANK YOU. Works like a charm.
0 Kudos