Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

I have grouped up a bunch of movies in directories on a USB drive from my Win7 system. When I use the app the recycled and system directories show up. is there a way to hide this? I have not found a way to delete these directories from the drive.
0 Kudos
Highlighted
Level 8

Re: roksbox -Streaming Local Media Channel Available for Tes

"farside847" wrote:
I have grouped up a bunch of movies in directories on a USB drive from my Win7 system. When I use the app the recycled and system directories show up. is there a way to hide this? I have not found a way to delete these directories from the drive.


Arent they in the root directory?
You can set Roksbox to start in a specified media directory.
0 Kudos
Highlighted
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

"farside847" wrote:
I have grouped up a bunch of movies in directories on a USB drive from my Win7 system. When I use the app the recycled and system directories show up. is there a way to hide this? I have not found a way to delete these directories from the drive.

What webserver are you using?
With Apache, you can include an IndexIgnore option in an .htaccess file (the file name starts with a dot). For example, my NAS creates indexed directories automatically that I do not want to be included in my file listing, so I use the IndexIgnore option, so the file listing will not show these directories or files. I then place the .htacess in the appropriate location on the webserver (for me, it is the /media directory). Here is what my .htaccess file says:
Order Deny,Allow
Allow from 192.168.0.*
Options +Indexes
IndexOrderDefault Ascending Description
IndexOptions FancyIndexing +IgnoreClient +Charset=UTF-8 +IgnoreCase +XHTML +NameWidth=* +DescriptionWidth=*
IndexIgnore @eaDir backup Thumbs.db *.nfo *.tgmd

Again, I believe this will only work with Apache so if you are using another webserver for Roksbox, please ignore this info. Also,I do not run Windows, but any Apache installation should be able to use an .htaccess file.
0 Kudos
Highlighted
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

the coding for the website needs to be made better!!!

Specifically the page for registration...Apparently...it doesn't work for firefox...at least not for me...I tried (on 2 computers, one running windows 7, one running Ubuntu 12.04) and it would not let me register because it says I cannot use any characters other than a-z, meaning no numbers..even though it takes an alphanumeric code...but IE on the windows machine allowed it. How do you screw that up so that firefox doesnt work??? Seriously.....
0 Kudos
Highlighted
Level 7

Setting Up on Mac - Forbidden Directory

Hello!

I am trying to setup Roksbox to be able to access files from an iMac. I have turned on the Apache server and created a /Users/Name/Sites directory. Then I go to http://127.0.0.1 I get the "It Works!" message which is a good sign. However, when I go to http://127.0.0.1/~Name/ I get the dreaded "You don't have permission to access /~Name/ on this server." I've tried setting the permissions to 777, as well as creating a name.conf file in /etc/apache2/users that looks like:


<Directory "/Users/Name/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>


I've played around with permissions and scoured the internet but I am out of ideas and would appreciate any help you can provide on other things to try!

Thank you SO much!
0 Kudos
Highlighted
Level 7

Re: Setting Up on Mac - Forbidden Directory

"KentyMac" wrote:
Hello!

I am trying to setup Roksbox to be able to access files from an iMac. I have turned on the Apache server and created a /Users/Name/Sites directory. Then I go to http://127.0.0.1 I get the "It Works!" message which is a good sign. However, when I go to http://127.0.0.1/~Name/ I get the dreaded "You don't have permission to access /~Name/ on this server." I've tried setting the permissions to 777, as well as creating a name.conf file in /etc/apache2/users that looks like:


<Directory "/Users/Name/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>


I've played around with permissions and scoured the internet but I am out of ideas and would appreciate any help you can provide on other things to try!

Thank you SO much!


I don't know the layout of a Mac, so I am assuming that there is a directory called /Users/Name/Sites/~Name (/Users/Name/Sites/~Kris for example) and you are trying to get there... I don't believe quotes are used, but I might be wrong...

On top of that, just try explicitly allowing the user directory to see if it works, then you know it is the subdirectory cascading that is the issue... Also, I usually put this stuff directly in my httpd.conf not in a names.conf or anything...
0 Kudos
Highlighted
Level 7

Re: Setting Up on Mac - Forbidden Directory

"krisbee" wrote:
"KentyMac" wrote:
Hello!

I am trying to setup Roksbox to be able to access files from an iMac. I have turned on the Apache server and created a /Users/Name/Sites directory. Then I go to http://127.0.0.1 I get the "It Works!" message which is a good sign. However, when I go to http://127.0.0.1/~Name/ I get the dreaded "You don't have permission to access /~Name/ on this server." I've tried setting the permissions to 777, as well as creating a name.conf file in /etc/apache2/users that looks like:


<Directory "/Users/Name/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>


I've played around with permissions and scoured the internet but I am out of ideas and would appreciate any help you can provide on other things to try!

Thank you SO much!


I don't know the layout of a Mac, so I am assuming that there is a directory called /Users/Name/Sites/~Name (/Users/Name/Sites/~Kris for example) and you are trying to get there... I don't believe quotes are used, but I might be wrong...

On top of that, just try explicitly allowing the user directory to see if it works, then you know it is the subdirectory cascading that is the issue... Also, I usually put this stuff directly in my httpd.conf not in a names.conf or anything...

I'm not very familiar with a Mac either, which is part of the problem, as I'm trying to help my step-dad set this up. But from what I've read, "Name" is your Mac ID which is where the default webserver is. All the files that you put in /Name/Sites/ is what gets shared in /~Name. The instructions to setup Roksbox on a Mac are out of date with some of the latest Mac updates which is why I need some help.

Thanks in advance, Mac users!
0 Kudos
Highlighted
Level 7

Re: Setting Up on Mac - Forbidden Directory

"KentyMac" wrote:
I'm not very familiar with a Mac either, which is part of the problem, as I'm trying to help my step-dad set this up. But from what I've read, "Name" is your Mac ID which is where the default webserver is. All the files that you put in /Name/Sites/ is what gets shared in /~Name. The instructions to setup Roksbox on a Mac are out of date with some of the latest Mac updates which is why I need some help.

Thanks in advance, Mac users!


What I would do is specify a location like
/Webserver

and then make that actually a symlink in reality to the root folder you wanted(/User/Kris or whatever)... This is what I did in my system, so as I needed to add videos/etc from my system, I would just drop a symlink in and that would work...
0 Kudos
Highlighted
Level 7

Re: Setting Up on Mac - Forbidden Directory

"krisbee" wrote:
"KentyMac" wrote:
I'm not very familiar with a Mac either, which is part of the problem, as I'm trying to help my step-dad set this up. But from what I've read, "Name" is your Mac ID which is where the default webserver is. All the files that you put in /Name/Sites/ is what gets shared in /~Name. The instructions to setup Roksbox on a Mac are out of date with some of the latest Mac updates which is why I need some help.

Thanks in advance, Mac users!


What I would do is specify a location like
/Webserver

and then make that actually a symlink in reality to the root folder you wanted(/User/Kris or whatever)... This is what I did in my system, so as I needed to add videos/etc from my system, I would just drop a symlink in and that would work...

I'm still not sure how to do this on a Mac, nor am I sure how to get around this "Forbidden" message. Does anyone have updated Roksbox step-by-step setup instructions for a Mac?
0 Kudos
Highlighted
Level 7

Re: roksbox -Streaming Local Media Channel Available for Tes

Brilliant software! Thanks

I installed Roksbox Cloud on my new Roku 2 and linked it. Works fine. Couple of questions

1. Options/My Options/Dropbox - this works fine but it is excruciatingly slow. Any idea how to speed I up? My wifi network is fine, I have no issues streaming Netflix

2. Not unrelated to #1 I can get my Mongoose web server to serve up photos from the alias /photos but is there a way I can also setup an alias to my local Dropbox folder on the same computer at say /dropbox or even /photos/dropbox and have Roksbox seamlessly serve that up? I haven't read up on the XML option yet, is that what it will take here? Help appreciated.
0 Kudos