Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
MadClown
Level 7

"Server connection error" using Roku Media Player in 8.1 update

Since the 8.1 update I get "Server connection error. Not able to connect to 'DLNA device' please check your connection" when playing back media files using DLNA on the Roku Media Player. Two different ways it happens, and both are random. The first happens on initial playback of a file. It'll just show the progress bar and act as if it will begin playback, but instead the progress bar will get stuck and then eventually send me back to the Roku Media Player menu with the error message. Weird thing is if I press the back button while the progress bar is stuck, and then immediately replay the file, usually it will play fine.

If I actually am able to play the file, the second behavior happens just randomly while watching. It will be playing back normally and then suddenly out of nowhere I get the server connection error. No clue to know when it'll happen. It can be 5 minutes, 30 minutes, an hour, or even longer. Just suddenly Roku will give the server connection error.

I didn't have any of these problems until my Roku updated to 8.1 4131 on june 29.

software version: 8.1.0 build 4131-04
Roku 3 4230X
Roku Media Player: 4.1 build 1579
0 Kudos
26 Replies
sven875
Level 7

Re: "Server connection error" using Roku Media Player in 8.1 update

So it's not just me. I have exactly the same symptoms and it all started with the update.
4620X
version 8.10 build 4137-29
0 Kudos
atc98092
Level 13

Re: "Server connection error" using Roku Media Player in 8.1 update

What are you using for a DLNA server? I have no issues with Serviio.
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos

Re: "Server connection error" using Roku Media Player in 8.1 update

I am having the same problem. Roku Premier.  I've tested with both Twonky Server 8.5 (licensed, running on a Qnap) and OpenMediaVault 4.  For me the player will start and play up to about 41 minutes then crash with a network error (connection to server lost).  Problem occurs with media files that played fine before the last update. No Changes to the network or servers.  The problem shows up on both of my Premiers.
0 Kudos
MadClown
Level 7

Re: "Server connection error" using Roku Media Player in 8.1 update

"atc98092" wrote:
What are you using for a DLNA server? I have no issues with Serviio.

I'm using MiniDLNA 1.2.1, but I didn't have any issues when I was on the previous version of Roku.
0 Kudos
RokuShawnS
Level 10

Re: "Server connection error" using Roku Media Player in 8.1 update

All, can you please post your serial number and DeviceID (if applicable) so we can investigate?  Thanks!

(Settings > System > About)
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
0 Kudos
MadClown
Level 7

Re: "Server connection error" using Roku Media Player in 8.1 update

Serial number: 632618163350
0 Kudos
RokuShawnS
Level 10

Re: "Server connection error" using Roku Media Player in 8.1 update

Oops!  I also need the DeviceID (if it shows one on that same screen).

Thanks!
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
0 Kudos
MadClown
Level 7

Re: "Server connection error" using Roku Media Player in 8.1 update

My Roku doesn't show the DeviceID on that screen.
0 Kudos
RokuShawnS
Level 10

Re: "Server connection error" using Roku Media Player in 8.1 update

"MadClown" wrote:
My Roku doesn't show the DeviceID on that screen.

The majority of older models, and maybe a few that have come out in the last three years, might not have a DeviceID.  Most of the latest models do.  If you don't have one, don't worry about it Smiley Happy.
We can still discover the DeviceID even if someone doesn't post it, but it will require an extra step that will make it take much longer trying to diagnose the issue.
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
0 Kudos