Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jdege
Level 7

YouTube app delay, when starting videos

For a couple of weeks, now, when watching videos on the YouTube app on my Roku 4, most of the time the video plays for perhaps half-a-second, freezes for 10-20 seconds, then resumes playing.

This happens only on the Roku app, I have no issues playing YouTube videos on any other computer or device on my network. And it's not happening on any other app on my Roku. Netflix, Hulu, all the others are fine.

It's getting rather tiresome.

Is YouTube throttling Roku, for some reason?

0 Kudos
andyross
Level 16

Re: YouTube app delay, when starting videos

It's a bug on the Roku 4. I have similar issues. It's a bit intermittent and possibly related to the OS 9.3 update.

0 Kudos
Jdege
Level 7

Re: YouTube app delay, when starting videos

Is it specific to the Roku 4?

 

That is, if I upgrade to a current model, would it go away?

0 Kudos
Nebo1ss
Level 9

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

I upgraded to the latest version of 9,3 4150. Using the same procedure. Upgrade remove tube, reboot device reinstall tube and still have problems. immediately after he update i thought the problem had been resolve because the first 3 or 4 video's worked without delay and then everyone since has the delay again.

Back to the drawing board for ROKU.

 

BoblK
Level 9

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

Yep.  This is the first time I have really ran into an issue ( other than the lack of DD support thru Optical out from YouTube TV, Netflix, Amazon Prime)..........The only thing that works right for that is PLEX.

It is frustrating.

0 Kudos
AmishRake
Level 7

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

Same issue, Roku 4, just updated to 9.3.0 4150 this morning and freeze on start still occuring. Really annoying and hope it is fixed soon. 

0 Kudos
smokeyPete
Level 7

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

Has anyone found a work around? I too am using the 4400x. I've done the factory reset too. I am using direct ethernet, HDMI and Toslink out to an HDMIfury Pro transcoder on my TV since the digital inputs on my TV went bad a few years back. Otherwise I'm a pretty average user. all my other apps are fine.

0 Kudos
cr8fusa
Level 9

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

I tried both my 4400's, worked on them both for 2 weeks and gave up. I'm using an Amazon Fire Stick now, it works very well.

Jdege
Level 7

Re: YouTube app delay, when starting videos

I checked for updates.

I was running 9.3, it had last updated on May 6, which was about when I first noticed this.

There was a later build of 9.3 ready to install.

I installed it.

It did not fix the problem.

Is Roku aware of this issue? Are they planning to address it?

0 Kudos
Jdege
Level 7

Re: Youtube Freeze Roku 4 (4400x) SW Ver 9.3.0 - 4132.17

I'm seeing the issue, as well.

Only on YouTube, only on my Roku.

No problem with YouTube on any other device, no problem with any other changes in my Roku.

Updated to build 4150, and nothing changed.

0 Kudos