Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
chrisgra
Level 7

Youtube stopped working on Roku 3 FIXED then broke again + more problems

Hello, I have a Roku 3 4200x software version 9.0.0 build 4084-04. (in fact 2 of them)
When I start the Youtube app as of today (my most frequently used app) I get a screen that says "Connection error Please reconnect to the internet" and a back button that does nothing.
My other apps appear to work correctly (i.e. are connected to the internet fine).
Same thing on my 2nd Roku.

I have tried restarting, restoring factory defaults, switching to WiFi from Ethernet and back, removing & reinstalling the app, all to no avail.

Any others with the same issue? Solutions? Did Roku 3 simply stop supporting YouTube? Thats what it appears to be...
EDIT: UPDATED TO BUILD 4114-04 and fixed it. Apparently this update was just released today.
EDIT2: Same thing happened again, fixed by removing the YouTube app, rebooting and reinstalling it. Still find it often doesn't display video thumbnails. Meanwhile, I also discovered that Amazon Prime videos no longer play and Xfinity does not load the channel guide and therefore I can't watch live TV.
Thanks
0 Kudos
3 Replies
mmcgloin
Level 7

Re: Youtube stopped working on Roku 3 FIXED then broke again + more problems

I'm having similar issues. I've uninstalled and reinstalled the app and my Roku OS is up to date but YouTube opens to black screen, I click OK, then it appears, but if I try to play any videos it gets stuck on the Ads. I think it's an issue with the ad network.
0 Kudos
atc98092
Level 15

Re: Youtube stopped working on Roku 3 FIXED then broke again + more problems


@mmcgloin wrote:
I'm having similar issues. I've uninstalled and reinstalled the app and my Roku OS is up to date but YouTube opens to black screen, I click OK, then it appears, but if I try to play any videos it gets stuck on the Ads. I think it's an issue with the ad network.

It certainly could be the ad network. But a question: when you uninstalled the channel, did you reboot the Roku before reinstalling? If you didn't, then it was never really deleted and you could still have the same problem embedded in there. Always reboot before attempting another installation. 

Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Community Manager
Community Manager

Re: Youtube stopped working on Roku 3 FIXED then broke again + more problems

Sorry to hear about the issue you're running into with the YouTube channel. 

If removing the channel from the Roku home screen, restarting your device, then adding the channel back once more doesn't resolve the issue, you'll want to reach out to YouTube directly to report the problem you are seeing and request additional support. They'll be able to best assist with any issues you are encountering when using their channel on the Roku platform. YouTube support is located here: https://support.google.com/youtube/?hl=en#topic=9257498

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
0 Kudos