Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
frank1492
Level 7

Youtube not working correctly

I have 2 Roku 3s and High speed internet (verified 30mbps) I live near Boston MA. All other channels work fine. When channel is activated on either Roku the YouTube logo screen just sits there with spinning progress circle. Clicking select brings up menu choices, select again results in black screen sometimes with audio in background. Was this way on March 8 and 9, evenings. Any ideas?
0 Kudos
51 Replies
Patrick133t
Level 7

Re: Youtube not working correctly

I see this, too. You can use the up and down arrows as a workaround, but it's not always reliable. Sometimes the OSD won't disappear afterwards.
0 Kudos
atc98092
Level 16

Re: Youtube not working correctly

The YouTube app on the Roku is, in my opinion, a disappointment. The only devices that it works well for me is my Ultra and 4. Both the TV and Stick have lags after button presses, especially when trying to FF. On my 2 XS it's completely unusable. But I will say on both the Ultra and 4 I have no such issues. It appears that YT designs their app for the highest powered boxes and don't particularly care if it doesn't work well on the lesser boxes. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
T_J
Level 7

Re: Youtube not working correctly

I watch YouTube on Ethernet connected Roku 2 (4210R) & Premiere Plus all the time. I have 1.28 Mbps DSL. Currently watching LIVE stream of SafariLIVE with the Roku 2, YouTube app working perfect. I also watched some LIVE SafariLIVE last night on Roku 2, YouTube app worked perfect then also. Picture quality looks pretty good on both my 26-inch Samsung and 40-inch Sony.
0 Kudos
atc98092
Level 16

Re: Youtube not working correctly

With the exception of the 2 XS, YT will generally play videos just fine. It's when you want to FF or rewind that the shortcomings appear. The UI is a little laggy on the TV and Stick, but tolerable. But the 2 XS will crash even just letting it play. But remember that the 2 XS is pretty old, and severely underpowered compared to the current models. Your version of the 2 has double the memory and significantly more power. And your Premiere + has double the memory of your 2, and again a significantly improved CPU, even over your 2.
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Azs91
Level 7

Re: Youtube not working correctly

I am having the same problem in Boston. I use the YouTube app on my Roku 3 all the time. Any fix?
0 Kudos
bvd1022
Level 9

Re: Youtube not working correctly

"frank1492" wrote:
I have 2 Roku 3s and High speed internet (verified 30mbps) I live near Boston MA. All other channels work fine. When channel is activated on either Roku  the YouTube logo screen just sits there with spinning progress circle. Clicking select brings up menu choices, select again results in black screen sometimes with audio in background. Was this way on March 8 and 9, evenings. Any ideas?

Hi Frank,


I'm not sure if it is a region related issue of some sort, but I had issues using YouTube on my Roku 3 for almost two years before being informed after an internet outage in my area and a call to my internet provider that my family and I were using in their words "Obsolete" equipment. Although as I told the tech who came out that I did not appreciate being told this until we had an issue with our equipment, a change of equipment to the current line the provider was using and an upgrade in speed miraculously solved the YouTube on Roku issue.  Before the change/upgrade in equipment what would happen when I would play a video in a playlist of mine is either a video playback error message would appear at least two, or three times before finally playing on the third or fourth try and the video would play in full without issue, but then when it went to go to the next video the same video playback error please try again message would pop up. 


It was very frustrating because Roku is my primary device that I use for streaming, but the issue did not happen on other devices I use. Although this initially led me to think that it was a Roku-related problem, it was that my connection/equipment was out of date and getting that resolved solved the problem.  My suggestion would be to make sure your internet equipment is current from your provider and also a wi-fi extender might help with stability of your connection. I had some relatives living with me for a while and they couldn't get a steady connection via our wi-fi, but purchasing an extender solved that problem and it provides a wider range for the entire home. If you get an extender, obviously I suggest making sure it is encrypted so only people you know are using it. Best of luck to you.
0 Kudos
edfardos
Level 7

Re: Youtube not working correctly

confirmed symptoms on both my roku3, no more youtube.   more victims of the internet-of-things zero change management and unintended consequences of being clever instead of stable?
0 Kudos
Highlighted
Dent
Level 7

Re: Youtube not working correctly

"frank1492" wrote:
I have 2 Roku 3s and High speed internet (verified 30mbps) I live near Boston MA. All other channels work fine. When channel is activated on either Roku  the YouTube logo screen just sits there with spinning progress circle. Clicking select brings up menu choices, select again results in black screen sometimes with audio in background. Was this way on March 8 and 9, evenings. Any ideas?

Hi guys, simple fix for YouTube on the Roku.  You need to restart/reboot the Roku.  Go to Settings, System, System Restart, then restart the Roku.  When it comes back on, YouTube works perfectly.
0 Kudos
edfardos
Level 7

Re: Youtube not working correctly

confirmed, restart/reboot roku fixed it, thanks!
0 Kudos