Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
necorchaos
Level 7

Youtube app slow audio startup

I'm having issues with the Youtube app.  When we first start a video, the audio doesn't start for 2-3 seconds.  If we rewind the video, audio starts normally.  We are using the Roku Ultra via ethernet.

I don't have this issue with Hulu, Netflix, Disney or other apps.  It appears to just be a Youtube thing.

Any itdeas?

0 Kudos
9 Replies
dathead2
Level 10

Re: Youtube app slow audio startup

Looks like there was a 20210330 youtube update. Mine doesn't do that though on ultra 2018

My Netflix just started having no audio for three seconds every time you rewind which kinda blows but not game ender. 

Roku Ultra 4660X
RokuOS 9.4.0 build 4200
Sony Bravia 55A8G TV
0 Kudos
overtimeman
Level 9

Re: Youtube app slow audio startup

My youtube channel has been doing this for a while now.Guess I'll keep looking for an update!

I used to have a life before Roku!
0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Youtube app slow audio startup

Hi everyone,

Thanks for the posts.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing? Please keep us posted what you find out.
 

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
necorchaos
Level 7

Re: Youtube app slow audio startup

I'm having the same issue.  Video starts, audio starts after 2-3 seconds.  It's not a huge deal, but we aren't seeing it with other apps.

We use a Amazon Fire Stick in other rooms and don't have this issue

0 Kudos
necorchaos
Level 7

Re: Youtube app slow audio startup

Didn't see a way to edit, but did some additional troubleshooting.

I have the Roku Stick+ in my den for some testing of applications for work.  The Youtube app works fine on the stick.

In the living room we do have a soundbar hooked up to our TV.  I have to adjust the volume seperately and can't use the remote.  It's possible the bar is causing a delay, but it's not happening on other apps, with our cable box or with the Firestick.

0 Kudos
overtimeman
Level 9

Re: Youtube app slow audio startup

Well I deleted the youtube app and did a system restart.Added the app back again and still have the 2-3 second delay when the commercial starts and when the actual video starts. Made sure eveything is updated too. Model 4800X-Roku Ultra Build 9.4.1 build 4237-C2---Youtube V 1.0 93000138

I used to have a life before Roku!
0 Kudos
dathead2
Level 10

Re: Youtube app slow audio startup

Tried remove reboot install for my Netflix audio issue.  No go. That’s a cold shot in dark usually.   Rewind still causes 2-3 seconds silence with video playing but no audio  

9.4.0</software-version>
<software-build>4200

version="5.0.98079411">Netflix

just like most of these issues they all started with the giant March 22, 2021 mega app update 

Roku Ultra 4660X
RokuOS 9.4.0 build 4200
Sony Bravia 55A8G TV
0 Kudos
necorchaos
Level 7

Re: Youtube app slow audio startup

I have "solved" the problem.  I changed the auto options from Auto to PCM.  Youtube audio now starts at the beginning of the video.  However, this has changed the sound levels for all of my apps instead of them being leveled out.  Seems like Roku and my soundbar were doing something to level things out.  Other apps like HBO, Hulu and others could send Dolby audio to the soundbar and have the sound start on time.  Youtube is doing something different.

0 Kudos
overtimeman
Level 9

Re: Youtube app slow audio startup

Thanks Bro,that fixed my youtube slow audio problem.My sound stand is refurbished ZVOX 670 I picked up at $199.Nothing fancy but it's several grades above what those TV speakers sound like.Appreciate the help!

I used to have a life before Roku!
0 Kudos