Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ChicagoboyRN
Level 7

Youtube app problems

It all started about a week ago.  Whenever we press Youtube app on our TV, it goes directly to the regular Youtube channel and not on YoutubeTV.  I thought i made a mistake and search for YoutubeTV app but there is none.

Also, whenever we tried to launch Youtube app, it just won't.  I tried deleting the Youtube app, then did System Restart.  Add the Youtube app again.  I do this at least 4 times a day.  It's beginning to be a hassle and time consuming.  Like i said, just started last week or so.  Could be from the latest Youtube app update?  I have about 7 channels added and i have no problem with those launching.

Please help

0 Kudos
4 REPLIES 4\
StreamerUser
Community Streaming Expert

Re: Youtube app problems

Opening the YT app should open YT (not YT TV) - thats expected normal behavior.

This also includes YouTube buttons on remotes - opening the YT app (not YT TV) is expected behavior.

If you dont have the YT TV app, you can launch YT TV from within the YT app (click on the YouTube TV link at the lower left in the UI menu).

You didnt mention your make/model/firmware version for your TV (Settings/System/About) or the YT app version (highlight press Options (*) on the remote).

Regardless, try these known solutions/workarounds for YT app not loading:

1) Change your Theme to the Roku Default (Settings/Theme/Restore default theme) - try again

2) Change your Screensaver to a Roku clock (Settings/Theme/Screensavers) - try again

3) Check for updates (Settings/System/System updates/Check now) - try again

4) Remove YT app, RESTART ROKU (Settings/System/System restart), Add YT app - try again

5) Network connection reset (Settings/System/Advanced system settings) - try again

6) Completely unplug power from Roku for 10-15 minutes - try again

7) Factory reset (Settings/System/Advanced system settings) <--- last resort

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
ChicagoboyRN
Level 7

Re: Youtube app problems

Thanks i'm gonna try it later.  Shall let you know what happens.

0 Kudos
Jimobrca
Level 7

All of a sudden was unable to load Youtube.....

Found this online and did the first 'work around'  and it worked.  Thanks very much.

0 Kudos
StreamerUser
Community Streaming Expert

Re: All of a sudden was unable to load Youtube.....


@Jimobrca wrote:

Found this online and did the first 'work around'  and it worked.  Thanks very much.


You're welcome - you can use the different steps/workarounds in the future if other apps dont load.

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos