Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
liger
Level 7

YouTube won't launch

Jump to solution

For the past few days, when I when I try to launch YouTube it gives me a can't run channel error "YouTube could not be run because there is not enough space. Please remove one or more of your installed channels and try again." I'm not having trouble with any other apps though, I can still add channels and no matter how many I remove, it doesn't do any good, so this seems to have little if anything to do with the real problem. I've tried unplugging the device, updating the system (but it's already up to date), uninstalling YouTube, rebooting the device and reinstalling it, but still the same error.
My Roku model is 3810x-Roku Streaming Stick+
Software version, 9.20.build 4806-50

1 Solution

Accepted Solutions
Kcain_65
Level 7

Re: YouTube won't launch

Jump to solution

I was having the same problem and I ended up uninstalling a screensaver I had downloaded (Auqatic Life) and restarted the device then and it finally worked. So If you have some screensavers downloaded that may be the problem.

View solution in original post

46 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: YouTube won't launch

Jump to solution

@liger 

Thanks for the inquiry.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing?

Thanks,
Danny

Danny R.
Roku Forum Moderator
liger
Level 7

Re: YouTube won't launch

Jump to solution

I've been trying this for days, and YouTube still gives me the same error message when I try to launch the reinstalled app.

BreaD365
Level 7

Re: YouTube won't launch

Jump to solution

I am having the exact same problem on my Roku Express, but on both my Roku 2 and 3, Youtube works perfectly fine. I have tried exactly everything you have. Also, it worked every day before.

Wingnut
Level 7

Re: YouTube won't launch

Jump to solution

Thanks Danny!

That did it!

Deleted the Youtube app, restarted the system, and re-installed the app. 

Works fine now.

RokuDanny-R
Roku Employee
Roku Employee

Re: YouTube won't launch

Jump to solution

@Wingnut 

That's great to hear. Thanks for letting us know.


Happy Streaming!
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Irena
Level 7

Re: YouTube won't launch

Jump to solution

There is not system restart option

MyUtubAppwntwrk
Level 7

Re: YouTube won't launch

Jump to solution

I have removed the YouTube app, restarted the TV and downloaded the app again with no success.

JayKelz
Level 7

Re: YouTube won't launch

Jump to solution

There is no system restart on my Roku TV.  My YouTube and YouTubeTV just out of the blue will not launch.  However it launches on every other device I have with no problem.

Babak
Level 7

Re: YouTube won't launch

Jump to solution

@JayKelz go to the power section. You can find restart or just simply unplug it and wait for 10 seconds. Plug it again and install the YouTube app. 

0 Kudos