Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Xfinity

Hello my xfinitu beta app isn’t allowing me to watch live tv. I checked with my cable provider and inquired about my issues. My cable plan isn’t the problem. The connection to Roku is and i need this issue resolved.

0 Kudos
6 Replies
Highlighted
Level 21

Re: Xfinity

Roku has no control over the functionality of that channel. It belongs to Xfinity, and only they can resolve it. As long as you can stream from other channels, there's nothing wrong with the Roku.

Comcast has called that channel a beta for years, and from all the problems I keep hearing about it, it doesn't seem they care about making it better. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
Level 7

Re: Xfinity

I'm having the same problem and I'm going to have to switch to AT&T TV if this issue can't be fixed. Comcast has been nothing but problems; from the apps to the techs. Horrible. 

0 Kudos
Highlighted
Level 7

Re: Xfinity

Hey,

I'm having the exact same issue.  I stream live TV through the Xfinity Stream Beta app and had been successfully doing so for the past year (I was watching live TV through it yesterday).  I get home from work today and when I try to view live TV through the Xfinity Stream Beta app through Roku I get a "error: TVAPP-00500" code.  I was on the phone with Comcast and they are adamant that everything is fine on their end.  The situation killed Roku's live customer support so I cannot get ahold of someone on the phone to try and resolve this issue.

The only reason I bought a Roku is to stream live TV through the Xfinity Stream Beta app (again, which I have been doing for about a year).  Now this Roku is useless to me.

0 Kudos
Highlighted
Level 21

Re: Xfinity


@Brenthalomue wrote:

Hey,

I'm having the exact same issue.  I stream live TV through the Xfinity Stream Beta app and had been successfully doing so for the past year (I was watching live TV through it yesterday).  I get home from work today and when I try to view live TV through the Xfinity Stream Beta app through Roku I get a "error: TVAPP-00500" code.  I was on the phone with Comcast and they are adamant that everything is fine on their end.  Covid-19 killed Roku's live customer support so I cannot get ahold of someone on the phone to try and resolve this issue.

The only reason I bought a Roku is to stream live TV through the Xfinity Stream Beta app (again, which I have been doing for about a year).  Now this Roku is useless to me.


I can understand, but Roku has no control of this. There have been no firmware updates recently, so there's nothing Roku could have done to cause an issue. Sounds to me like Comcast is being their typical cable company and deflecting their problem to someone else.

That said, the first thing to try when there's an issue with a channel is to remove the channel, reboot the Roku (critical step, do not skip), then add the channel back in. Sometimes, and especially when they continue to call it a beta, the code gets corrupted, and a removal cleans it up and puts the fresh code in its place. But don't forget the reboot, or the removal wasn't complete and the bad code can still be there. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
Level 7

Re: Xfinity

I've tried removing the app, rebooting Roku and reloading the app numerous times and that hasn't worked. :/

0 Kudos
Highlighted
Level 21

Re: Xfinity


@jc111 wrote:

I've tried removing the app, rebooting Roku and reloading the app numerous times and that hasn't worked. :/


Yeah, had to try. It’s something with Xfinity then, regardless of what they claim. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos