Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

So I can’t even find the Xfinity stream app on my premiere 3920x? Where is it? Also I don’t have a search function and my options button is light grey and doesn’t work!

0 Kudos
Level 8

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

It's not an automatic initial view. Find the xfinity box in ROKU and click it. You have to log into your xfinity account on the internet and request a code that you enter into the ROKU unit to activate the stream if this is the first time running it.

 

Update: as of 10 p.m. E.S.T. the xfinity app was repaired and is now working again on the first time I select a channel. It's a shame It took more than a week to solve such a simple coding problem.... but glad it is now up again since I turned in my cable tuner boxes.

View solution in original post

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

@R_jason Thanks for the note. Based on your description, it sounds like you are using a Roku device on a non-US Roku account, or connected to a non-US network connection.

The Xfinity Stream Beta channel is only currently available on Roku in the US channel store, and requires your Roku device to be directly linked to a US Roku account, and connected to your Xfinity network connection in the US. Any use of VPNs, or non-Xfinity network connections are not supported by the channel. 

Please feel free to contact Xfinity customer support for any other questions or additional assistance here: https://www.xfinity.com/support/contact-us

 

Thanks,

Tanner

 

Tanner D.
Roku Community Manager
0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

I am having the same issue since yesterday (01/16/2020).  The app was working fine up until the day before.  Now I get a black screen with the word "Initializing..." at the bottom...then the infamous "Sorry, something went wrong..." screen.

Tried uninstalling the app and re-installing...no luck.  I have a valid Xfinity account and use Xfinity for internet access.  Nothing has changed.

Anyone find a solution...don't really want to spend an hour on the phone with Comcast/Xfinity.

Update (01/16/2020):  I solved this issue this morning by rebooting my router...uninstalling/reinstalling the Xfinity Beta app...then restarting my Roku and selecting the Xfinity beta app.  I was then directed to reauthorize my Roku...by going to xfinity.com/authorize...logging in and entering the on-screen code.   All good!  Thanks everyone!

View solution in original post

Highlighted
Level 7

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

I’ve gotten the app to load once and then I get an error message that it failed to load. Then it takes me back to initial sign in phase which takes me to enter the code again that then says error.  Repeat, repeat, and repeat. 

0 Kudos
Highlighted
Level 8

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

That seems to be a different problem. They have since repaired the issue I was talking about.

 

There is a two-fold process in getting Xfinity to operate on Roku. The first is to list in Roku you want the Xfinity app included in your viewing choices. Once that is done, you have to activate your specific Roku device with Xfinity.  You have to log into your Xfinity account and add the device. They will ask you for a code to pair that device with Xfinity.  If you do not do this step, it will default you out of the Xfinity channel.  Also, make sure your Roku device is one of the listed approved devices. That could be another source of issues.

Xfinity Roku Pairing - you must have your Xfinity name and password 

0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

I’ve been having trouble for about a week now with the app on my Roku tv. I spent an hour on the phone with Xfinity and they couldn’t figure out the issue. Said it must be something with Roku. When I try to sign in I keep getting “Sorry, unfortunately we cannot support high speed data customers without a video subscription. Check out Xfinity.tv/shop to subscribe today!” It worked fine until recently

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Xfinity Beta App Issues

Jump to solution

@JackBauer23 Thanks for the note. That type of error indicates that the Xfinity account you are using isn't recognizing the digital subscription service required in order to use their channel/app on a device such as Roku. You'll need to contact Xfinity support again to review your account and configuration to ensure that you have this service added. This error is generated by the channel itself and not your Roku device, so Xfinity will need to assist you in resolving the issue in your account. 

After they review your account and subscription information, I might recommend de-authorizing the channel on your Roku device, removing the channel from the Roku home screen, and then restarting your device from Settings>System>System restart. Once the device restarts, then try adding the channel back once more and logging in again. 

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

If  finite is not regignizing my account, why would it work in 1080 resolution but not 4K?  I clearly have authorized access, but the app is not delivering a 4K image to Roku with an Ethernet connection to a Netgear C7800 high speed modem. I have all the bandwidth I need with the best router on the market, but am not using a rental router. 

0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

All I had to do is reset my xfinity modem.  The beta app came right back.  

0 Kudos