Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Xfinity Beta App Issues

Jump to solution

I have been having this issue with the Xfinity Beta App for days now. I start the app in Roku, app say "initializing" then I get a black screen that says- Sorry! Something went wrong. Please try again later (Error).

I've deleted the application then restarted the device from Settings>System>System restart with no success.

 

5 Solutions

Accepted Solutions
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

Sorry to hear about the issue you're running into! 

As a reminder, the Xfinity Stream Beta channel requires you to use an Xfinity internet connection, and have a valid subscription that includes this service. If removing the channel, then restarting your device before adding the channel back again isn't clearing up the issue, please follow up with Xfinity directly to report the issue and request additional support. You can reach Xfinity Support here: https://www.xfinity.com/support/contact-us

 

Thanks,

Tanner

View solution in original post

0 Kudos
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

@Misleo7 wrote:
I’m having the same issue. I called Xfinity and spent over an hour on the phone with them while trying to troubleshoot the problem. I was told to call or go online to Roku! Now you’re saying it’s Xfinity? The app works fine on my mobile devices, it’s my Roku devices it’s not working on.

Yes, it's Xfinity. They are the developers of the channel/app, and only they can resolve the issue. You can't compare the app on different devices, because they are all likely written in a different programming language. Roku absolutely uses a different language than an Android or iOS device, and even Windows or Linux. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.

View solution in original post

0 Kudos
Highlighted
Level 9

Re: Comcast Xfinity Stream app Beta not working

Jump to solution

It's not an automatic initial view. Find the xfinity box in ROKU and click it. You have to log into your xfinity account on the internet and request a code that you enter into the ROKU unit to activate the stream if this is the first time running it.

 

Update: as of 10 p.m. E.S.T. the xfinity app was repaired and is now working again on the first time I select a channel. It's a shame It took more than a week to solve such a simple coding problem.... but glad it is now up again since I turned in my cable tuner boxes.

View solution in original post

0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

I am having the same issue since yesterday (01/16/2020).  The app was working fine up until the day before.  Now I get a black screen with the word "Initializing..." at the bottom...then the infamous "Sorry, something went wrong..." screen.

Tried uninstalling the app and re-installing...no luck.  I have a valid Xfinity account and use Xfinity for internet access.  Nothing has changed.

Anyone find a solution...don't really want to spend an hour on the phone with Comcast/Xfinity.

Update (01/16/2020):  I solved this issue this morning by rebooting my router...uninstalling/reinstalling the Xfinity Beta app...then restarting my Roku and selecting the Xfinity beta app.  I was then directed to reauthorize my Roku...by going to xfinity.com/authorize...logging in and entering the on-screen code.   All good!  Thanks everyone!

View solution in original post

Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution

This worked for me as well. What was key though was re-booting the Xfinity Modem, not necessarily the router as that did not fix for me.  It’s key that you re-activate the Xfinity account through the xfinity site with the code as part of the process.  All other attempts without that step failed for me.

View solution in original post

0 Kudos
84 Replies
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

Well, they do call it Beta for a reason. You'll really have to contact them to see what's happening. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

Sorry to hear about the issue you're running into! 

As a reminder, the Xfinity Stream Beta channel requires you to use an Xfinity internet connection, and have a valid subscription that includes this service. If removing the channel, then restarting your device before adding the channel back again isn't clearing up the issue, please follow up with Xfinity directly to report the issue and request additional support. You can reach Xfinity Support here: https://www.xfinity.com/support/contact-us

 

Thanks,

Tanner

View solution in original post

0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution
I’m having the same issue. I called Xfinity and spent over an hour on the phone with them while trying to troubleshoot the problem. I was told to call or go online to Roku! Now you’re saying it’s Xfinity? The app works fine on my mobile devices, it’s my Roku devices it’s not working on.
0 Kudos
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

@Misleo7 wrote:
I’m having the same issue. I called Xfinity and spent over an hour on the phone with them while trying to troubleshoot the problem. I was told to call or go online to Roku! Now you’re saying it’s Xfinity? The app works fine on my mobile devices, it’s my Roku devices it’s not working on.

Yes, it's Xfinity. They are the developers of the channel/app, and only they can resolve the issue. You can't compare the app on different devices, because they are all likely written in a different programming language. Roku absolutely uses a different language than an Android or iOS device, and even Windows or Linux. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.

View solution in original post

0 Kudos
Highlighted
Level 7

Xfinity buffering and stoppage

Jump to solution

This year I purchased a Roku 3920X and a new LG television.  Our multi-station Eero is about a year old.  We have Xfinity and use their DVR.  I can watch free Roku, Netiflix, Tubi etc without a problem.  Trying to watch live TV or watching DVR programs through the Xfinity app is impossible.  After a bit, the buffering starts and then typically degrades into a total lock.    The same effort in the same location with my iPhone is not a problem.  

Any suggestions please?

 

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Xfinity buffering and stoppage

Jump to solution

[post merged to already existing related thread]

Hi,

Thanks for letting us know about the issue that you are experiencing.

Try removing the Xfinity channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the Xfinity channel back once more. 

If you are still seeing the issue, please follow up with Xfinity directly to report the issue and request additional support. You can reach Xfinity Support here: https://www.xfinity.com/support/contact-us


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution
I'm having the same issue
0 Kudos
Highlighted
Level 19

Re: Xfinity Beta App Issues

Jump to solution

@alott11  Thanks for the note! If the troubleshooting steps above aren't resolving the issue, you'll want to reach out to to Comcast Xfinity support directly to report the issue, and request additional support. Each channel (app) on the Roku platform is developed and maintained by the channel provider directly. They'll be able to assist you further. 

 

Thanks,

Tanner

0 Kudos
Highlighted
Level 7

Re: Xfinity Beta App Issues

Jump to solution
I’m having the same issue with my xfinity beta app on my Roku 4K. It’s displaying an error code of (Error setDeviceProvision.11005) It’s happened to my in-laws last week and it’s still not fixed. I live in the Chicago land area. Does anyone have more info about this problem? I spoke with xfinity and Roku support last week for my in-laws with negative results (no help at all). They just blame each other for the problem.
0 Kudos