Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
proto57
Level 8

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

UPDATE! I ended up answering my own question... that is, how to get the ROKU app to allow me to register on my laptop at all, since the app was only giving me the options to register the youtube app on my TV screen or phone.

Since the log in screen was still open on the TV, I thought I would click "sign in on phone", to see what would happen, even though I didn't want to do it this way. This brought up another screen, which gives ANOTHER option at the bottom, called, "Try another way", or like that. It is when you click on THAT, that it gives the option sign in with a browser.

I did that, using the suggested "youtube.com/activate" rather than "youtube.com/tv/actvate", and yes, all my search history is back, and all my subscriptions are intact.

Well you all probably knew all this, but for anyone else with this problem, I lay it out here.

Thanks for all the help and advice...

Proto57

0 Kudos
MrMark
Level 10

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

It may help you to go back and read the last part of @Psilobite 's step 3.

It certainly isn't intuitive that none of the options offered in the interface actually work, but that's the reality of the situation.  For me, it only works from a real computer.

As for the commercials, I bowed to Google and bought my way out of the commercials. ..everything is working out according to Google's evil plan:
https://www.wavsource.com/snds_2020-10-01_3728627494378403/tv/simpsons/burns/excellent3.wav

 

 

Tags (1)
0 Kudos
Psilobite
Level 12

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

@proto57 wrote:

I've been reading with interest all the related problems, and suggested solutions to this. It's really great that everyone is trying to solve it. Nothing has worked for me, however.

The most valuable advice seems to be that one should activate through "youtube.com/activate" rather than "youtube.com/tv/activate". But I cannot do either, because the only choices given me are to:

1) Sign in with your TV

2) Sign in with your phone

There is NO option for me to sign in on my laptop, which I think every other ROKU app allows. And signing in on the TV only brings me back to this broken ap, with no search history. But the fact that some of you were able to use this solution suggests to me that I may be either missing something/doing something wrong; or have a different device, software, or setup. What thinks you all?


"Sign in with your phone" --> "Try another way"

 

0 Kudos
mdphilps
Level 7

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

Started working for me tonight.  I didn't do anything different - but just saw my watch history now showing up.

Am I just lucky?  or did YT or Roku finally fix this issue?

Thanks!

0 Kudos
Fretman
Level 7

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

Yes, appears to be fixed now.  I think the issue was with Youtube as I had the issue with Roku, Firestick, and my Vizio TV.  Thanks for the update.

0 Kudos
atc98092
Community Streaming Expert

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

@mdphilps wrote:

Am I just lucky?  or did YT or Roku finally fix this issue?


It was never something Roku could "fix". It was solely under the control of Google in the YT channel.

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
MrMark
Level 10

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

Well...something happened, but it isn't clear who did what. 

Here's a little story. On the 16th, I used a Roku that has been powered down for a few months.  It worked fine, but since I was just watching one of my local recordings, I had no reason to check the history.  I usually turn off the physical switch on the power strip when I'm not using that TV, but that night, I forgot to power it down, so it's not hard to imagine that the Roku would have updated itself.

Today, the 18th, after reading here that something had changed, I went to that same untouched Roku to see if anything had changed.  What I found was that the Roku had become unresponsive.  I changed the batteries in the remote, thinking that they might have given their last energy on the 16th, but the Roku was still unresponsive.  At that point I point, I hard-cycled the power, and the Roku came back to life, although there were some seconds of unresponsiveness and unusual screen flashes.

When it finally settled down, I checked the history, and there was none, but I noticed too that I was no longer logged in.  Very interesting.  Then, just for fun, I logged back in from the TV interface, which hasn't worked for a long time, but this time it did.  I logged into my main account and my brand channels came along with the main one.  I didn't spend a lot of time with it, but there was some history showing.  I have not verified as to whether the history propagates between devices.

So then I looked at the software version and noticed that it was 10.5.0 build 4208.  I also noticed that the date of the last update was on the 16th.  Roku posted a press release about 10.5 on September 20th, but no way to tell when any specific device would have received the update, and certainly no way to tell when build 4208 arrived.  But internet chatter about 4208 seems to have started just recently.  People are complaining of audio dropouts, loss of Tablo DVR functionality, YouTube not loading and/or freezing..lots of grief surrounding 10.5.0.

So maybe Google fixed it, but it also seems possible that Roku may have fixed it with build 4208.  If indeed it actually is "fixed".  I need to try switching my other Roku's back to "normal" logins and then spend some time with it.  I hope all of you guys will do the same and then let me know what you see.  If it's fixed, then I guess I'm glad, but I would have liked it a lot better if someone would have acknowledged the problem and let us know what it took to make it work again.  The lack of transparency is irritating.

0 Kudos
Fretman
Level 7

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

I still think it's something on the Youtube side that got fixed.  Because not only is it working on Roku, it's also working on my Firestick TV and Vizio smart TV.

0 Kudos
MrMark
Level 10

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

'Certainly not above Google to roll out changes without any transparency!  One might think there would be a change log somewhere, but I have not seen it.

0 Kudos
Blanch_10
Level 7

Re: Watch history not updating on Roku TV YouTube App

Jump to solution

I know it's been a few weeks since somebody posted in this topic, but the advice given helped me before, so I figured I'd put the question to you all, if you're able to answer it. 

I had the same problem a few months ago; removing the app, reinstalling it, and trying the youtube.com/activate thing did the trick, for me. But now it's happening again, and I've tried removing the app, reinstalling it, and doing the youtube.com/activate thing (I'm using my brand account on the YouTube app, as its the one that has my watch history on it), and it keeps telling me I need to sign into my primary account (not my brand account) to confirm my age to watch certain videos. 

So, when I DO do that, and in the process link the brand account to the main account, when I access the brand account via that route, there is no search history. I'm able to watch age-restricted videos, but the search history is gone. I can't confirm my birth date on my brand account because the brand account doesn't have the ability to do that. I've tried going back and forth between the linked main account and the solo brand account and it's happened every time. I'm at my wits' end, honestly. 

Your advice: What should I do? 

0 Kudos