Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
n6mon
Level 7

Strange login issue with Amazon Prime Video

Weird Issue. When I log on to Prime Video from my Roku, it signs into amazon.co.uk. I am in the US and have both US and UK Amazon accounts. Because of the wrong sign on, I can not see any of the videos on my playllist.

0 Kudos
2 REPLIES 2\
RokuDanny-R
Roku Employee
Roku Employee

Re: Strange login issue with Amazon Prime Video

@n6mon

Thanks for the post.

For more information about that channel's account authentication and functionality, you'll want to contact Amazon Prime Video support directly to inquire further. Many channels on Roku are developed and maintained by the channel provider themselves. 

You can reach Amazon Prime Video support here: https://www.primevideo.com/help
 

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
makaiguy
Community Streaming Expert

Re: Strange login issue with Amazon Prime Video


@n6mon wrote:

Weird Issue. When I log on to Prime Video from my Roku, it signs into amazon.co.uk. I am in the US and have both US and UK Amazon accounts. Because of the wrong sign on, I can not see any of the videos on my playllist.


Sounds like your Prime Video app on your Roku is logged into Your UK Amazon account.   While in Prime Video, click on the icon in the top right that looks like a gear, then click on sign out.   Now sign back in, being sure to use your US Amazon account credentials.

One more possibility comes to mind:  Are you connecting to the internet via a VPN that masks your actual location?

Doug
Roku Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Roku Streaming Stick 3600

Roku Community Streaming Expert
I am not a Roku employee, just a user like you.

If this post solves your problem please help others find this answer by clicking "Accept as Solution."
0 Kudos