Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Re: Sling does not load

Jump to solution

Which internet service do you have?  I suggest you contact them and describe your problem.  I'm in a rural area and have wireless internet service, which has it's shortcomings.  In my case, my ISP sent one of the techs out to my house.  He aimed my antenna to a different tower which helped, but there are still times when I have to try 5 or 6 times to get Sling to load.

If you haven't already done so, try unplugging your ROKU device, wait 20 seconds or so, then plug it back in.  Once it initiates, try Sling again.  It's a pain, but sometimes that helps.

0 Kudos
Highlighted
Level 7

Re: Sling does not load

Jump to solution

Sling is NOT loading on my Roku TV. Firestick loading is very fast on 2 other TVs. Overall my Roku TV UX experience is horrible. Glad I got my Roku TV for free when I won it at a company Xmas party. Feel sorry for the suckers that actually paid for a Roku TV-they need to be compensated for Roku shortfalls!

0 Kudos
Highlighted
Level 7

Re: Sling does not load

Jump to solution

Roku needs to refund my Sling costs as it will not load on Roku TV. Horrible UX experience-demand a refund from Roku if your Sling does not work, as they are the problem-not Sling. My 2 other TVs with Firestick rapid load and it’s great! Roku is sooooo 1990!

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Sling does not load

Jump to solution

@enroar 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. 

If the issue remains unresolved, I'd recommend reaching out to SlingTV directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the SlingTV channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://help.sling.com/

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: Sling does not load

Jump to solution

I finally got someone at Sling TV to answer a call.  It's a very convoluted process and of course, didn't work.  I just cancelled my Sling TV subscription and will definitely not use them again.

0 Kudos
Highlighted
Level 7

Re: Sling does not load

Jump to solution

Same issue. I have tried everything. 

SN-YF0024404677

Version-9.3

Build-4194-55

ID-CT3782404677

0 Kudos
Highlighted
Level 8

Re: Sling does not load

Jump to solution

I still think the problem is with my ISP.  I'm in a rural area and have a wireless internet service.  From time to time, something goes wrong and Sling will not load (but Roku still works).  However, if I use my Verizon cellphone as a mobile hotspot, Sling loads up and performs flawlessly.  But the Verizon service has a data limit, so I can't continue to use it.  You might want to try that and see if it solves the problem.  At least that gives you a comparison to your regular internet provider.  Let me know if possible.

0 Kudos
Highlighted
Level 8

Re: Sling does not load

Jump to solution

The latest explanation from my ISP is this:  It normally provides it's customers with a dynamic IP address which is drawn from a pool of IP addresses.  The dynamic IP address you are given may change from time to time.  So, it's possible that Sling will not load if you've been given a dynamic IP that Sling detects is from outside the United States.  I asked the tech at my ISP why it would provide me with an IP address that's from outside the US.  He couldn't answer; it's drawn from a pool and they have no choice.  Sounds insanely ridiculous to me but that's their story and they're stickin' to it!  He said the same thing happens with HULU, and that their solution is to provide the customer with a Public IP address instead of a dynamic IP address.  Sling says they don't allow a connection if their customer's IP address appears to be outside the US.  So there you are:  finger pointing on both sides with the customer stuck in the middle.

0 Kudos
Highlighted
Level 7

Re: Sling does not load

Jump to solution

update:

I signed up for Sling Blue.

I can’t get past the Logo.

I did everything suggested here and at Sling.

Sling said I could still have Sling Free. No, I can’t get past the Logo.

I have TCL Roku TV.

Sling Blue works on my iPhone and my iPad Mini 5 but I don’t want to watch TV on my iPhone or my iPad 5.

The problem is Sling not working af ROKU.

It seems to me thus problem is between Sling and Roku.

Please deal with this problem.

Sling is the only streaming TV service with news I want to see, so I can see both sides before the election.

Connie Dodson 

October 7, 2020

0 Kudos
Highlighted
Level 8

Re: Sling does not load

Jump to solution

Connie, please remember this is a ROKU community board in which users attempt to help one another.  It's not like tech support from ROKU or Sling.

I'm still having the same problem as you:  Sling will not load, and I'm still waiting for my internet service provider (ISP) to find a solution.  I signed up for Sling Blue back in February and for months it worked just fine.  Then, about 2 months ago, I started having problems.  The error codes from Sling indicate that the Sling app is seeing an ISP address that resides outside of the USA.  Sling always blames my internet service.  My internet service says the problem is with the dynamic IP addresses that they assign from a "pool" of IP addresses.  They tell me they need to assign a "public" IP address.  That's supposed to be done today, but so far hasn't happened.  I'll put up another post when that's completed and let you know the result.

0 Kudos