Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jaymoe67
Level 7

Screen Mirroring Bug, Help NEEDED...

I'm having issues with the screen mirroring feature on my Roku 55" tv, which i've had for nearly 2yrs now... and haven't had any issues utilizing this feature untill suddenly, 90 days ago... I have all the permissions properly dialed in on the tv, (Allow, / Promt, etc...). My phone is Samsung Galaxy S9 + ..). Normally, I initiate  via the phone, (smartview/ select name of TV, / then select proceed anyway on tv remote...)Then the purple screen appears with the image of the pares...and voila... I recently found a thread in this community talking about (What was my initial suspicion: "Firmware bug") Mind-you, already I have approached roku support directly, only to get nowhere... What I believe needs to happen to resolve this issue is for me to find a direct link to the "Firmware Fix", download to a flash drive, then insert it directly into the TV and force it to install/update directly. Whats happening now is a message as in the photo.... I know someone else out there has likely run-into this problem before me...  And yes, I'm already gonna say it... I'd normally be connected to 2.4 frequency on my phone, I do have capabilities of switching to 5g as well...

Rocast.PNG

0 Kudos
4 Replies
StreamerUser
Level 16

Re: Screen Mirroring Bug, Help NEEDED...

Did you happen to disable "Device connect"?  (Settings/System/Advanced system settings/Device connect=Enable 'Device connect')

If its disabled, you won't be able to use Screen Mirroring.

Restart your Roku TV after enabling it (Settings/System/System restart).

 

0 Kudos
Jaymoe67
Level 7

Re: Screen Mirroring Bug, Help NEEDED...

NO!!!! I did not disable anything.... Like I stated, I have everything enabled, permissions... set to "prompt" & Allow... Ive even gone as far as a "factory restore"... !!! and no results...Have you seen the screen shot I posted up in my message... ??? What the **bleep** is RoukuCast??? I didn't have to install anything when I initially got this thing,... everything worked right outta the box... I can go to my buddies place, whom has the identical TV as I, and it'll work... If you have any positive insight that would be appreciated..

 

0 Kudos
Jaymoe67
Level 7

Re: Screen Mirroring Bug, Help NEEDED...

I did however, finally acquire the firmware update file, onto my flash drive which I'll pluginto my tv when I get home from work tonight... hopefully That'll resurrect this dam thing from purgatory.... 

0 Kudos
StreamerUser
Level 16

Re: Screen Mirroring Bug, Help NEEDED...


@Jaymoe67 wrote:

NO!!!! I did not disable anything.... Like I stated, I have everything enabled, permissions... set to "prompt" & Allow... Ive even gone as far as a "factory restore"... !!! and no results...Have you seen the screen shot I posted up in my message... ??? What the **bleep** is RoukuCast??? I didn't have to install anything when I initially got this thing,... everything worked right outta the box... I can go to my buddies place, whom has the identical TV as I, and it'll work... If you have any positive insight that would be appreciated..

 


You didnt mention "Device connect" before, hence why I asked if you disabled it (it disables screen mirroring, amongst other things).

Yes, I saw your screenshot - its why I asked if you disabled "Device connect".  RokuCast is Roku's Miracast receiver app (its hidden) - this has to be loaded in order to screen mirror.  In order to be loaded, it may have to be downloaded (its an app).   Like any app, it auto-updates when run and something appears to be preventing this.

I dont know whether this error message happened before your factory reset, or after, or both, but this message and others very similar to it can happen when (among other reasons), disabling "Device connect".

If your TV doesnt have the latest firmware, that could be the issue - reinstalling (or upgrading, if its an upgrade) the firmware may fix the issue.

0 Kudos