Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
atc98092
Level 13

SOLVED: RMP not offering any audio

This is mostly directed toward RokuDale, but I wanted to post this publicly in case someone has had this happen. 
.
I bought a new Premiere for my sister-in-law this morning. Install and setup went perfectly, sync'd Amazon and Britbox without a problem. However, when I use RMP to stream media from her computer, the video plays fine but no audio. DLNA server is Serviio. Regardless of the profile used, no audio would play. When pressing the OK button, the display always showed NONE for the audio codec. The only way I could change that was to change the Roku HDMI audio setting from Auto to Dolby Digital. RMP would then show DD, but still no audio. I tested Amazon, Britbox and The Roku Channel, and they all have audio. The media I've tried to play are all ripped DVDs (using MakeMKV) with either DTS or DD audio. Roku firmware is 9.0, but I didn't note the build number. Display is an older Toshiba 1080 LCD (non-smart TV). The media all play fine through a Sony Blu Ray player, so for now she can still use that as her home media player. But I really want to figure this out. She doesn't have a second TV to test it on. I didn't bring it home with me to test on one of mine because she was anxious to try using Britbox. But I'll do that if we can't come up with something else.
.
Doesn't seem likely since audio  works with all other channels, but is a defective box a possibility? 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
9 Replies
RokuDale
Level 8

Re: RMP not offering any audio

Do you have any of the volume leveling/night mode options enabled?
Did you try any files with mp3 or AAC audio? Something that the Roku would decode itself?
0 Kudos
atc98092
Level 13

Re: RMP not offering any audio

"RokuDale" wrote:
Do you have any of the volume leveling/night mode options enabled?
Did you try any files with mp3 or AAC audio? Something that the Roku would decode itself?

No audio settings enabled. Didn't have any files with anything but DD audio. I did try setting the Roku to PCM output, but RMP still displayed no audio codec and there was no sound. With all my experience, this has really baffled me. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
RokuDale
Level 8

Re: RMP not offering any audio

Since the premier can't decode dolby, you'll need to feed it aac or some other audio codec it can decode internally.
Since it says NONE for audio when you click ok while the video is playing, it has decided that there is no audio track that it can play so it is only playing the video.
Setting the digital audio mode to PCM means that it will only pick audio that it can decode internally, which means no dolby,dd+,dts.
It will only be able to play AAC,wma,mp3,flac, etc.
The older Toshiba might be only able to take PCM for audio. You might need to make sure your serviio server is transcoding all audio to AAC.
0 Kudos
atc98092
Level 13

Re: RMP not offering any audio

"RokuDale" wrote:
Since the premier can't decode dolby, you'll need to feed it aac or some other audio codec it can decode internally.
Since it says NONE for audio when you click ok while the video is playing, it has decided that there is no audio track that it can play so it is only playing the video.
Setting the digital audio mode to PCM means that it will only pick audio that it can decode internally, which means no dolby,dd+,dts.
It will only be able to play AAC,wma,mp3,flac, etc.
The older Toshiba might be only able to take PCM for audio. You might need to make sure your serviio server is transcoding all audio to AAC.

Thanks Dale. I was expecting the Roku to pass AC3 to the TV, which should be able to play that with no issue. But that TV is likely more than 10 years old, so maybe it can't. Still strange that the Sony BD player and even the old Media Player I gave her originally sent audio. Maybe they were converting the AC3 to something else. If you're saying the Premiere can't do that, then I'll have to build a new profile for her. I should have tried the Chaneru profile, since that one uses HLS and AAC audio. But it still transcodes when unneeded, so I guess a new profile is going to be necessary. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
RokuDale
Level 8

Re: RMP not offering any audio

If you select Auto in the hdmi digital audio out, it will tell you what your TV can do (detected). If it says PCM, that's all it can decode Although some old TVs will pass Dolby and DTS through to their optical connector, even if they don't decode it. You should be transcoding to HLS if possible as you can ffd/rew,resume where you left out when using RMP.
0 Kudos
atc98092
Level 13

Re: RMP not offering any audio

If I have the time I'll go back out to her house tomorrow and try the Chaneru profile. If I get audio, then that's the solution. I'll just take one of my Roku profiles and modify it to HLS and AAC audio. I can't recall what the screen said when I had Auto selected. Most likely it's the age of the TV. Since the Premiere was playing the H.262 video without issue, just transcoding the audio is all I need to do. Her computer can handle that with no issues. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
atc98092
Level 13

Re: RMP not offering any audio

Solution, but it's still strange. When HDMI was set to auto, it didn't show any supported codecs, but I also forgot to scroll over to see the window. Whoops!
.
I tested the Chaneru profile, and finally had audio. So it appears that for some reason the TV will only accept AAC audio. I can't explain why the Sony BD player and SMP-N200 media player both would play the audio just fine. I don't think either of them would transcode the audio. So my guess is the TV and the Roku couldn't agree that DD was acceptable.
.
I built a special profile just for her player, first leaving the video alone and just transcoding the audio to AAC. Since the Premiere plays MPEG-2 video just fine, this worked well. But, I thought for her usage having the ability to use trick play functions would be more important than reducing the load on her computer. So I switched the profile to transcode the video to H.264 with HLS encoding, and all is well. I just couldn't believe a 1080p TV with HDMI inputs, even as old as it is, wouldn't accept DD from the Roku. Well, as old as it is she'll probably be replacing it in the not too distant future, and any new TV should be fine.
.
Thanks for the assistance, Dale!
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
RokuDale
Level 8

Re: SOLVED: RMP not offering any audio

Actually the TV is not accepting AAC audio, it is only accepting PCM stereo. The Roku is converting the AAC audio you are sending to PCM stereo before sending it to the TV.
It is very likely that both the SMP and Sony are sending PCM stereo to the TV. If you can show that the TV is getting DD from Sony or SMP and handling it, please post an update.
0 Kudos
atc98092
Level 13

Re: SOLVED: RMP not offering any audio

Yeah, I meant to say PCM. I don't think that TV has any sort of display to show what it is receiving, but I'll try to remember to look next time we visit her. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos