Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
Agen7_0range
Level 7

Roku update 05/09/17 - mkv codec error that could play fine yesterday

As title states, Roku shows an update at 3:45 PM today and we are now unable to watch a video from our server that we were able to watch yesterday.  Rebooted and no resolution.  Any input or suggestions would be appreciated as this was running fine until the update it seems.

Thanks
0 Kudos
26 Replies
RokuDale
Level 8

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

What updated? The firmware? Or was it the RMP app that updated? What type of server? What type of machine is the server running on? Also what is the model of the Roku?
0 Kudos
Agen7_0range
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

Roku 3
Synology DS211j NAS
I will have to check the details on the update as I only recall going into the main roku menu options - updates and saw last update was 3:45 PM

As mentioned, this video and others like it all played without issue the day before.  I will get more details on what update I was looking at when I have access to the Roku again.  I appreciate the quick reply.

EDIT:  It was a system upgrade.
0 Kudos
Smoku
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

I am having this same issue.  My last update was May 10 7:26 PM EST.  Software 7.6.0 build 4125-04, on my 4230X Roku 3.  Yesterday I was watching some MKV files, today they would not play from USB (with a codec error), or from DLNA server citing, "No compatible media found in: All Videos".
0 Kudos
Faceofboe
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

I second this.  Had movies that played fine off a network devices and now I get a warning that the audio codec is not supported.  Roku 3 using your media player app.
0 Kudos
auujay
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

I suspect I have the same problem.  I am streaming files from a NAS via Emby Server and the Emby Roku channel (version 3.0 build 24).  I reached out to them and the errors they saw from the logs indicated that the Roku video component was failing to play the file and to reach out to Roku.  Are there suggestions on the best way to test this while bypassing Emby, just to see if it is true that the Roku suddenly cannot play these files (built-in app to connect to network share or maybe I should use the microSD card slot)?

I see this issue on a number of Blu-Rays I have encoded myself with Handbrake.  They are 1080p mkv's encoded at a pretty high quality including 4 ref frames but as others have indicated these used to play without issue in on my Roku in the past (that is why I encode with those settings).  Then a few days ago I kept getting this problem.  Files that fail will fail every time, usually they will play for a few seconds or a minute and then just stop.

Device Details
Model: 4210X - Roku 2
S/N: 4A6523084657
Software Version: 7.6.0 build 4125-04
Wired connection
Cable internet (but problem file is being streamed from local wired network)
HDMI connect to Denon receiver which goes via HDMI to the Panasonic plasma.
The NAS streaming the content is an AMD A6 running unRaid OS and Emby media server. The files are being streamed through Emby to the Roku.
0 Kudos
speechles
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

Just as follow up to @auujay. I am the developer of the emby blue neon night app (67397). In as much, I have learned a few things over the last 2 years regarding what the roku likes and dislikes as far as the video player was concerned. As of late, the last 7.5 update, and more recently carried over into the 7.6 firmware there are some video player problems which can reboot the device. This is the same issue as @auujay has, but involves a different part of the video player component. This one affects the refframes allowed when using a roku3, or any variant with a model number of 42**.

Please see this thread for reference: https://emby.media/community/index.php? ... p-suddenly
and this is @auujay's thread: https://emby.media/community/index.php? ... w-minutes/

In the first thread above, I play the problem item several ways (I am goldilocks, to roku co's three bears):

"force direct" which isnt right because the roku3 cannot decode aac5.1 and neither does my end device. This results in a working video stream, but silence as an audio stream. No good, next!

"force transcode" which in this case, copies the video stream and transcodes the audio stream from 5.1->2.0. This will crash the roku video player, lockup the roku3 and reboot it. Fatal error. No good, next!

"force transcode without stream copy" forces the video to transcode at a bitrate of 1 below the video bitrate, a full video transcode. This will play perfectly on the roku3 as both the video stream and audio stream are being transcoded by the emby server. This is just like baby bear's bed, just right! Smiley Happy

If any samples are needed to show proof of this problem, I can provide them. I am presently just confirming that a few of my apps users are having issues and I can confirm these as reproduceable on my end, but out of my hands to correct.  Happy users make me happy. Thanks for your time and any help you can offer.

Note: Before the last 7.5 update this video worked perfectly on the roku3, using auto-detection, which acts the same as "force transcode" does in this video's case. As mentioned above, since "force transcode" reboots the roku, so will auto-detection in my app presently do this. This is why users are having so many problems, they are used to the auto-detection being top notch, which it was prior. This video, for reference, works perfectly on 7.6 on my roku ultra using any play method: forced direct, forced transcode, and forced transcode without stream copy..
0 Kudos
RokuDale
Level 8

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

 @speechles I've sent you a PM.
If anyone has a small file they could make available? I can send an invite to a box account. Please let me know.
Thanks
rokudale
0 Kudos
RokuDale
Level 8

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

Also, anyone else having this problem, please send to me your SNs of the device.
thanks
rokudale
0 Kudos
auujay
Level 7

Re: Roku update 05/09/17 - mkv codec error that could play fine yesterday

I can re-create it with a 4 minute (236 MB) .mkv I just made using my normal Handbrake settings; RF=21 with Preset: Slower and Tune: Film and Profile: High 4.1 (using ref=5 and bframes=5).  I played it via a USB stick on the Roku Media Player app. I get the same behavior as I get with my normal movies using Emby and the application Speechless described above.  When it plays it does not exit the app or reset the Roku, rather it shows a "Loading..." screen for a second or two a few times throughout the clip.  If it would help I can also upload a cell phone video of it playing on my TV so you can see what it looks like.
0 Kudos