Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
Paper_jam
Level 7

Roku Express+ issues w/ Amazon Prime Video after 8.1 update

On my Roku Express+, I've noticed some glitchy behavior with Amazon Prime Video app since receiving update to 8.1.0, on June 29.
Symptoms: While playing a video using the Roku Amazon Prime Video app, the "video control overlay" (don't know what term to use) showing play/pause/FF/REV status and time remaining, is behaving oddly. When using the Roku's remote control arrow keys to select features or commands, they disappear or turn black, instead of being highlighted as they normally would. Also, when I use the "back" button to exit the Amazon app, the OK and CANCEL options presented on the screen are in black text and not highlighted, making it more difficult to identify what choice you've selected. Fortunately, video playback itself still appears to work normally, as does the interface screen while browsing movies and TV shows.

Supplemental Note: I'm not seeing this problem with Netflix or Youtube apps, only Amazon Prime Video.

  • Roku Express+ (3900RW)
  • Firmware 8.1.0 build 4137-51
  • Problem has been occurring since June 29 (and is still occurring)
    if it could possibly matter, this is with Roku set to output 720p video due to TV limitation. Have not tried other resolution settings to see if issue persists.

    Thank you.
  • 0 Kudos
    2 Replies
    kaminokokb
    Level 7

    Re: Roku Express+ issues w/ Amazon Prime Video after 8.1 update

    I am experiencing the same issue, however mine is with a Roku TV instead of a Roku Express.  When I access a video on the Roku Amazon Prime Video app, video controls are partially missing when I click the down arrow on the remote control to access them.  When I first click the down arrow, the play button is missing. The rewind, fast forward, and next episode buttons are present, along with the back arrow on the left, and the closed caption button on the right. If I use the arrow key to select any one of these buttons, they disappear, and do not reappear unless I force-close the app by using the home button, and re-start the app. The video will play normally using the play/pause button, but that is about it.  This happens on any TV program or movie in the app.  It does not occur in any other streaming channel such as Netflix. The problem also does not happen on my Samsung tablet, iPhone, a laptop or a Chromebook.  On all of these devices, the Amazon Prime Video App works exactly as it should. It only occurs on the Roku TV.

    I have tried the following fixes, but nothing has worked so far-
    -deleting and reinstalling the app
    -powering off the TV and the wifi
    -doing a system update via the system menu at the following thread: system/system update

    I have not done a factory reset yet.  Specifications for my system are below.  

    Roku TV  7302X
    Insignia model  NS-50DR620NA18
    Software Version 8.0.0  build 4183031

    Any help is most appreciated,
    Kathy B.
    0 Kudos
    Bacon
    Level 9

    Re: Roku Express+ issues w/ Amazon Prime Video after 8.1 update

    Same issues with disappearing buttons on my Premiere+ with the Amazon app.

    8.1 is not good...
    0 Kudos