Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 14

Roku 4 and MotorTrend streaming channel

I recently subscribed to MotorTrend (separate from the cable subscription based MTGo). On my Roku 4, I have noticed an issue. After playing just one video, it gets very sluggish and can take several seconds to respond to remote commands. When I try to exit, it won't actually close. I have to hit the HOME button to get out of it. Once out, the Roku works normally. I'm aware this is probably more of an issue with the MT app and not the Roku.

I did a test with an Express 3900 in another room, and that didn't appear to have any issues. Both the 4 and Express are updated to OS9.3. The app itself is also up to date on both (I only added it a few days ago.)

Curious if this is just limited to the Roku 4, or if other models have a similar problem?

0 Kudos
1 Reply
Highlighted
Roku Employee
Roku Employee

Re: Roku 4 and MotorTrend streaming channel

@andyross 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing?

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos