Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Roku 3700x channels stopped working one at a time

I recently moved about 30 miles north and 1,000 feet higher (Colorado mountains). My roku worked fine for the first month, then slowly each channel has stopped working. An error message pops up that says “Can’t run channel! because it could not be reinstalled from the network. Please check the network and try again.” I also can’t add new channels or delete and reinstall them. My wireless network is running fine, and my connection strength is excellent. I’ve restarted my roku 3 times with no change, and it is completely up to date. What now? Please, help!

0 Kudos
2 Replies
Highlighted
Roku Employee
Roku Employee

Re: Roku 3700x channels stopped working one at a time

@RobinRD 

Thanks for the note.

Have you tried removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. Does this clear up the issue you are seeing?

If the issue is still not resolved, I would recommend removing all the channels and trying to perform a factory reset on your device and linking the device back to your account.

For more information about how to perform a factory reset, visit our Support page here: How do I factory reset my Roku® streaming device?

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: Roku 3700x channels stopped working one at a time

@RokuDanny-R 
Thanks for responding.

I should clarify, I can delete channels just fine. I cannot, however, reinstall them. Or install any new channels. That’s when the error message pops up. I will try the factory reset.

Robin

 


 

0 Kudos