Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Stevew1
Level 7

Roku 1 wont play youtube

2710x with latest system software. Removed youtube channel app. Restarted roku. Added youtube back to make sure it is the newest version. Still have the same problem. Loads app, get a blue square on left of screen. Red band on right. After 3 or 4 seconds exits back out to home screen. Any suggestions?
0 Kudos
7 Replies
Highlighted
malonejt
Level 7

Re: Roku 1 wont play youtube

Hi, You are not alone. I have the same exact issue. After 15 seconds or so, YouTube closes and reverts back to the Home Page. I am wondering if my Roku 2 device is now outmoded, or if the problem stems from signal strength? I hope someone out there in the vast Roku universe has a solution to this problem.

0 Kudos
Highlighted
malonejt
Level 7

Re: Roku 1 wont play youtube

Solution: Continually press the OK button as YouTube loads. This solution was provided by a uses on another forum. It worked for me! 

0 Kudos
Highlighted
BernieceB
Level 7

Re: Roku 1 wont play youtube

We are having the same issue! On the OK button solution ours just freezes. We have reset the ROKU to Factory. I have unplugged it and plugged it back in. We have 2 other Roku's and it works on them. Any suggestions are appreciated. 

0 Kudos
Highlighted
leemelone
Level 9

Re: Roku 1 wont play youtube

The OK button solution briefly worked for me until I reported it as a possible clue to why it keeps crashing. Then it stopped. I've tried reporting it numerous times to YouTube and Roku. All I got was the standard remove, reboot, re-install procedure which does nothing. My suggestion is to watch YouTube on your other devices because it's becoming pretty clear that no one is going to fix this issue.

0 Kudos
Highlighted
atc98092
Level 17

Re: Roku 1 wont play youtube

The Roku 2710 was released in Sept 2013, so it's really old. I have a 3100 that is similar vintage (a little older) and it's worthless with YouTube. Google has designed the channel for more recent players with more substantial hardware. I'm not trying to talk you into spending money, but you really should consider replacing that old of a player. You are going to encounter channels failing more often, as they are developed for newer players. Also, just saying you have the current software isn't enough, as different players receive updates at different times. Your player is old enough it might no longer receive Roku updates, so knowing exactly what software you are on can help. 9.2 is the latest version, but you might still be on 9.1. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
leemelone
Level 9

Re: Roku 1 wont play youtube

I bought both of my 2710Xs at the end of 2015. I don't consider four years "really old" or "vintage". You're wrong about it not receiving current updates. It's still on Roku's current list of update-able devices and mine has the latest 9.2 update. The update from ROKU (not YouTube) is what is appears to be causing the problem. If you read all the recent posts about this issue, most of them started when their device updated. I wish Roku would either fix the problem or admit that the 2710X is no longer a currently supported device.

0 Kudos
Highlighted
atc98092
Level 17

Re: Roku 1 wont play youtube


@leemelone wrote:

I bought both of my 2710Xs at the end of 2015. I don't consider four years "really old" or "vintage". You're wrong about it not receiving current updates. It's still on Roku's current list of update-able devices and mine has the latest 9.2 update. The update from ROKU (not YouTube) is what is appears to be causing the problem. If you read all the recent posts about this issue, most of them started when their device updated. I wish Roku would either fix the problem or admit that the 2710X is no longer a currently supported device.


Sure, you bought them in 2015, and I agree that four years isn't old, even for electronics. But the 2710 was first released two years before you bought yours, so the design and hardware are a little over 6 years old. That's great that you still get the latest updates, which means it's still considered a supported player. I must say that surprises me, but still good for users that still have them.

But hardware-wise your player isn't much more powerful, if at all, compared to my 2 XS (3100), and mine is worthless with YouTube. Yours has a 600 MHz CPU (dual core I believe), where the latest versions of Roku have a CPU with double the speed and four cores. The performance difference between the two is very significant. Also, your player doesn't support Netflix Profiles, so I would expect Netflix to begin dropping support for those as well. They really want people to use the latest user interface, which I personally hate, and was one of the reasons I dropped Netflix completely. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos