Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Cdh
Level 8

Pop up banner

I have had Roku for years with no issues.  As of yesterday, all apps have this annoying pop up banner that appears every 2 minutes and lasts for 15-20 seconds.  It says LED - MCI - Dolby - LTriple XD along with other titles.  It is annoying and interferes when I want to use captioning.  How can I get rid of it?  I have googled with no success.  I am having issues with xfinity streaming but this banner pops up with all apps.

0 Kudos
12 REPLIES 12\
andyross
Level 16

Re: Pop up banner

That is coming from your TV, not the Roku. It is somehow in Store or Demo mode. You need to go through it's settings.

0 Kudos
StreamerUser
Community Streaming Expert

Re: Pop up banner

Your LG TV is in Store Mode - you need to put it in Home Mode:  Settings/General/Home Mode (at the very bottom of the menu)

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Cdh
Level 8

Re: Pop up banner

Thank you for responding but I can't get to " Settings/General/Home Mode (at the very bottom of the menu)".  I don't have those options in Roku or Xfinity app and it is not for lack of trying!  No "General" under Settings!  Should I be looking elsewhere?

I am thinking of doing "System restart" but I don't want to get into deeper problems than I have now.

0 Kudos
StreamerUser
Community Streaming Expert

Re: Pop up banner

Its your LG TV that is giving you the message - not the Roku.

You need to adjust your LG TV's settings as I described above.

FYI, a system restart wont hurt your Roku (helps many issues in fact) - however, in this case, its not your Roku - its your LG TV.

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Cdh
Level 8

Re: Pop up banner

I meant a factory reset!  Please, how do I get to LG's settings?  When I turn on TV, I am in Roku.

0 Kudos
StreamerUser
Community Streaming Expert

Re: Pop up banner

Get your LG TV's (model unknown) remote, press the Settings button, General, scroll down to Home/Store Mode and select Home Mode.

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Cdh
Level 8

Re: Pop up banner

This TV is LG29LB4505.  Worked perfectly for years until yesterday!

I am not getting prompts you directed me to through settings.

0 Kudos
Cdh
Level 8

Re: Pop up banner

Spoiler
OK, only with your help I got it back to normal!  I would never have thought to use the LG remote!  Had to hunt for it since I never had to use it!  I fiddled with settings and removed "demo" mode to standard and pop ups are gone!  I would never have been able to do this on my own.  Thank you so much for sticking with me!  Have a blessed day!
0 Kudos
StreamerUser
Community Streaming Expert

Re: Pop up banner

Try Settings/Option/Mode Setting=Home Use

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos