Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Kylio1
Level 7

Pluto tv

Jump to solution

When I'm watching photo TV it works normal then goes blank for a few then comes back up normal why is that I just bought a brand new TV the TV works great is it Pluto TV itself?

0 Kudos
1 Solution

Accepted Solutions
RokuDanny-R
Roku Employee
Roku Employee

Re: Pluto tv

Jump to solution

@Kylio1

Thanks for the inquiry.
Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. Does this clear up the issue you are seeing?

If the issue remains unresolved, I'd recommend reaching out to Pluto TV directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the Pluto TV channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://support.pluto.tv/hc/en-us
 

Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
1 Reply
RokuDanny-R
Roku Employee
Roku Employee

Re: Pluto tv

Jump to solution

@Kylio1

Thanks for the inquiry.
Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. Does this clear up the issue you are seeing?

If the issue remains unresolved, I'd recommend reaching out to Pluto TV directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the Pluto TV channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://support.pluto.tv/hc/en-us
 

Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos