Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Whatarussh
Level 7

Plex - Audio Sync Issue

I'm also having audio sync problems on the Roku Ultra. Plex audio works perfect on our Sharp Roku TV so it is unique to a software problem on the Ultra. The issue only happens with videos played via the Plex App, not Netflix or Disney just Plex.

I'm tired of bad software updates and then slow fixes from Roku. The Plex audio sync problems has happened before with the Ultra. I'm about ready to sell this thing and buy Apple TV. Considering this is Roku's top of the line device and their core-competency this should be the best product and software on the market. Apple TV is way more stable. 

8 REPLIES 8\
jpicco
Level 7

Re: Plex - Audio Sync Issue

I'm having what seems to be the same problem, and it has also happened on Criterion Channel app. 

Dansheen83
Level 7

Re: Plex - Audio Sync Issue

Hi, I'm having a similar issue with my Roku streaming stick. Recently the video and audio can go out of sync with one another. Exiting to the home screen and resuming puts the audio and video back in sync for a time but it eventually goes out o sync again. Can anyone recommend a workaround or fix? Thanks in advance

0 Kudos
ppwaskie
Level 7

Re: Plex - Audio Sync Issue

I’m having the same issue, which started recently, but on a Roku Premier, and a Roku Ultra.  I run my own Plex server on a Linux host, and have been for a number of years (pushing 8 years).  I had Plex server 1.21.1-r1 (it’s a Gentoo server), and I had zero issues with audio sync. One I upgraded the server (currently at 1.21.2.3939), I’ve had audio sync issues.  It seems to happen wherever a commercial hits, or right at the start of a show or movie.  If I back the Roku player up by one tick (10 second jump I think), that re-sync’s audio...until another commercial break.

This is happening on pretty much all the content I have, which is a mix of h.264, h.265, 720p, 1080p, 2160p, with stereo, AC3, DTS, doesn’t seem to matter.

I downgraded my server back to 1.21.1-r1 and the issue goes away.  But obviously I can’t keep it on there forever.

It’s worth noting that my Nvidia Shield TV Pro has zero issues with audio, nor does the Plex apps on my iPad or Android phone.

If I can provide any logs, info, whatever, I’m happy to try and help.  This is a very frustrating issue, and I’m hoping it can get resolved soon.

0 Kudos
Pil71
Level 8

Re: Plex - Audio Sync Issue

Same problem here.  Roku streaming stick+ running Plex client.    

Roku are not responding.  Plex have 'emailed' Roku that's it.   Need to bang together the heads of these two corporates that really don't get the concept of customer service.

0 Kudos
Brandon_006
Level 7

Re: Plex - Audio Sync Issue

@Dansheen83 The quick workaround is to turn off Direct Play in the Plex app settings on your Roku device.

0 Kudos
Crawtater
Level 7

Re: Plex - Audio Sync Issue

In my case, the delay usually goes away when i disable and then re-enable leveling/night mode on the Roku itself during playback (hit the * button and turn it off, get out of the leveling menu, then * and turn it back on if you want).  Sometimes, I just have to leave it disabled.

 

I've noticed this across quite a number of apps on the roku ultra and premiere+ models for more than a year...not only Plex, although the latest app updates for others (HBOMax, Disney+, etc) seem to be better lately, but not Plex.  Nothing I do on my plex server side or app side settings seem to help.

MarkyM
Level 8

Re: Plex - Audio Sync Issue

In my case, I have 3 new Roku Express 4k Plus units.

When playing my own 4k UHD videos (shot on my DSLR, no movie rips etc.) using the Roku Plex app, the audio & video are noticeably (and unusably) out of sync. The sync is OK on 1080p videos and on all of the other Roku apps that do 4k (Netflix, Disney+ etc.)

In my main system, I have a 2019 Nvidia Shield Pro sitting right next to the Roku and it's Plex app plays these same 4k UHD videos in perfect audio & video sync. The same for the LG 4k TV's app in my second system.

The audio on these 4k videos is AAC Stereo at 384kbps. The video is UHD, MP4, SDR, 30p @45mbps. I also tried PCM audio and that was the same or worse. I timed the delay and it's a full 2 seconds!

It is not a bandwidth issue as the videos are all well under 50mbps which my network handles just fine.

I can get perfect sync by disabling Direct Play, but that transcodes the 4k videos to 1080P. Changing the audio leveling setting on & off has no effect.

This is repeatable on all 3 Rokus.

0 Kudos
MarkyM
Level 8

Re: Plex - Audio Sync Issue

UPDATE...

I tried lowering the video bitrate to 35mbps (audio AAC @384kbps). This is the lowest recommended UHD SDR bitrate per YouTube's upload guidelines.

Now the sync appears to be OK!

So perhaps this is a Roku hardware limitation?

To summarize, 45mbps, MP4, UHD, SDR, 30P videos with AAC 384kbps stereo audio play in perfect sync using the Nvidia Shield Pro Plex app but are about 2 seconds out of sync using the Roku Express 4k Plus device's Plex app.

35mbps MP4, UHD, SDR, 30P videos with AAC 384kbps stereo audio seem to play in sync on both devices.

OK then.

0 Kudos