Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Benedlr
Level 10

No video on streaming when switching from OTA.

I get a grey screen and audio on streaming when using the 'previous' button to switch from OTA. It will connect with one second of video and then go grey. Back and forth using the button until streaming stabilizes. Sometimes twice does it, other times five. After five I go to Home and re-enter the channels to stabilize the change between those two only. Doesn't happen every time but often enough to be annoying. Add this to the audio lag when switching between OTA channels, a short viewing period on the TV Guide and other glitches. Roku makes you work for free tv.

0 Kudos
3 REPLIES 3\
Ello2022
Level 10

Re: No video on streaming when switching from OTA.

So I imagine your speaking about a Roku TV. Roku doesn’t make TVs. They only make the software. Your TV was made by TCL, Hisense, ONN or something else. So when you are watching your OTA channels and switch to something like Netflix this happens? You can watch your OTA channels right from within the Roku Live TV. 

0 Kudos
demsd
Level 13

Re: No video on streaming when switching from OTA.

This happens when switching from one OTA channel to another, or OTA to a Roku channel?

Roku Ultra 4670X
40" TCL Roku TV
50" TCL Roku TV
0 Kudos
Benedlr
Level 10

Re: No video on streaming when switching from OTA.

Happens just about every time when switching from OTA to the Roku streaming channels. A blip of video on every switch to streaming with the 'previous' button. Audio is instant and fine. Just a gray screen on streaming. OTA is fine.

0 Kudos