Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: NFL App fails to login

I'm having the exact same problem. Did you figure it out?
0 Kudos
Highlighted
Level 7

Re: NFL App fails to login

I was having the exact same problem. Tried to log in multiple times, both by clicking to watch NFL Network live and also by trying to log in under Settings--TV Provider login. It finally worked after I clicked on CBS All Access Sign in under Settings, then clicked the back button to go back to Settings, then clicked TV Provider sign in. Not sure if clicking on CBS All Access had anything to do with fixing the problem--it may have just started working again on it's own after a few minutes and me clicking on CBS was just coincidental.
0 Kudos
Highlighted

Re: NFL App not working

Mine will not work still uninstalled several times and nothing same loading circle for hours.
0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: NFL App not working

Hi,

Thanks for letting us know about the issue that you are seeing. I didn't have any issues with the channel when I tested it this morning.

Try removing the NFL channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>Power>System restart. Once your player starts up again, add the NFL channel back once more. Does this clear up the issue you are seeing?

Please keep us posted.

Thanks,
Danny
Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: NFL App not working

Just tried those exact steps Danny and its still spinning. This is ridiculous
0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: NFL App not working

Hi,

Thanks for letting us know about the issue that you are experiencing.

Is NFL the only channel that you observe this issue with? It's possible there may be an issue within the channel itself that the service provider will need to investigate. 

I'd recommend reaching out to NFL directly to report the issue and request additional support. Many channels on the Roku platform is developed and maintained by the channel provider directly, and they'll be able to best assist. 

You can contact them through their support page here: https://digitalcare.nfl.com/hc/en-us/requests/new

If you need more help from there, please feel free to PM with your player model details including the ESN from Settings>System>About. I'll help take a closer look to see what else we can suggest.

Thanks
Danny
Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: NFL App not working

I have been having this same issue off and on for the past 4 months.  I have 5 Roku Ultra's and they are all just spinning and not playing, very frustrating.

0 Kudos
Roku Employee
Roku Employee

Re: NFL App not working

Hi,

Thanks for letting us know about the issue that you are experiencing.

Is NFL the only channel that you observe this issue with? It's possible there may be an issue within the channel itself that the service provider will need to investigate.

Try removing the NFL channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the NFL channel back once more. Does this clear up the issue you are seeing?

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: NFL App not working

Glad to see the robot Danny is alive and well and giving the same answer over and over despite it not working. I’m having the same issue and it’s ridiculous that this has persisted for over a year without a resolution.
0 Kudos
Highlighted

Re: NFL App fails to login

I'm having the same problem now. Worked fine earlier in the week. Nothing is working. Anyone find a fix?

[merged threads]

0 Kudos