Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mototrend causes my 4800x to reboot

I just got a new 4800x.  On the Motortrend channel when I start a show, about 30 to 60 seconds in the screen goes to all white snow, stays like that for 5 or 10 seconds and then the Roku reboots.  I don't have this issue on any of my other Rokus (Ultra (4700x?), a Roku 2 and a Roku 3).  This has been happening since I got this new Roku.  I have no issues with any other channel.

If I go back into the Motortrend app and play the same video it works.  If after that I start a second one, the box crashes.

I have uninstalled Motortrend, rebooted and reinstalled the channel 3 or 4 times.  Last night I did a full factory reset and the problem has not gone away.

I have another issue with this box where when I switch to it, there is no video output.  I can tell that the box is up because I can see it on the mobile app and I see the light blinking when I hit remote commands but I get no video output until I power it off and on.  This was also not solved by the factory reset.

 

Could I just have gotten a faulty Roku?

SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos