Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
baxio
Level 7

Issue playing audio from USB Roku Media Player

Hi,

I have a Roku 2 box which developed a problem early December when playing a folder of AUDIO files in Roku media player, part way through playing a song a message pops up that says:

"Audio playback failed.

The file contains no video tracks"

It finishes the song and won't play the next until you acknowledge the error, and it does this on every song so I can't leave music playing in the background without having to press OK all the time. 

I believe a recent software update caused the error. I bought a second Roku 2 and it updated to the latest software and does the same thing.

I've uninstalled and reinstalled the app and factory reset the Roku box but the error persists. Roku support seem to be working off a script and asking me the same 3 questions on repeat.

Please help!!!

Dan

https://www.dropbox.com/s/13r4r0qx1ub30 ... o.jpg?dl=0
0 Kudos
19 Replies
Community Manager
Community Manager

Re: Issue playing audio from USB Roku Media Player

Thanks for reaching out. Sorry to hear about the issue you're seeing. Could you please provide some additional details so we can take a closer look?

- What file format are the tracks you are trying to play? 
- Does the same issue occur on audio tracks encoded in a different format? 
- If you create a new folder and move the tracks into it, does the same issue occur? 
- What source are the audio tracks stored on? (USB drive, network drive, etc.) 

With more information, we can look into this further to see what may be causing the issue. 

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
atc98092
Level 16

Re: Issue playing audio from USB Roku Media Player

There's more than one model Roku 2, so we need to know specifically the model number of your player. But even newest version of a Roku 2 is years old, so if you bought a new one it's not "new". The last Roku 2 (model 4210) was introduced in April 2015, but the older versions go all the way back to 2011. 
.
Most importantly is finding out what audio codec is in use, and what the container is. The container is the 3 alphanumeric characters at the end of the file (.MP3, .WMA, .MKV, etc.) Roku supports a number of containers, but not all. The audio codec is even more important, as again there are only certain ones that Roku supports. A program like MediaInfo can show the codec information easily. There's a way to do it with FFMPG from the command line if you're comfortable with that. 
.
Have you selected Audio in the RMP main selection window when you first start it (this is in reference to the message about no video tracks)?
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
baxio
Level 7

Re: Issue playing audio from USB Roku Media Player

"RokuTannerDB" wrote:
Thanks for reaching out. Sorry to hear about the issue you're seeing. Could you please provide some additional details so we can take a closer look?

- What file format are the tracks you are trying to play? 
- Does the same issue occur on audio tracks encoded in a different format? 
- If you create a new folder and move the tracks into it, does the same issue occur? 
- What source are the audio tracks stored on? (USB drive, network drive, etc.) 

With more information, we can look into this further to see what may be causing the issue. 

Thanks,
Tanner

-A mixture of WMA and MP3 files. The issue happens on both
-I have the files in a number of folders, and it happens regardless of which folder it is in
- This is files stored on a USB stick
Thanks,
Dan
0 Kudos
baxio
Level 7

Re: Issue playing audio from USB Roku Media Player

"atc98092" wrote:
There's more than one model Roku 2, so we need to know specifically the model number of your player. But even newest version of a Roku 2 is years old, so if you bought a new one it's not "new". The last Roku 2 (model 4210) was introduced in April 2015, but the older versions go all the way back to 2011. 
.
Most importantly is finding out what audio codec is in use, and what the container is. The container is the 3 alphanumeric characters at the end of the file (.MP3, .WMA, .MKV, etc.) Roku supports a number of containers, but not all. The audio codec is even more important, as again there are only certain ones that Roku supports. A program like MediaInfo can show the codec information easily. There's a way to do it with FFMPG from the command line if you're comfortable with that. 
.
Have you selected Audio in the RMP main selection window when you first start it (this is in reference to the message about no video tracks)?

It's a Roku 2 (UK) - 4205EU, software version 9.0.0 build 4114-04
Yes, I am using the audio option in the Roku Media Player option. It worked with the same files for months up until some point in December, where I suspect a software update broke it.
Dan
0 Kudos
RokuDale
Level 8

Re: Issue playing audio from USB Roku Media Player

Does it always happen with the same files on the USB drive?
And in the same place? If so can you isolate at least one of the files so that we can examine it?
0 Kudos
baxio
Level 7

Re: Issue playing audio from USB Roku Media Player

"RokuDale" wrote:
Does it always happen with the same files on the USB drive?
And in the same place? If so can you isolate at least one of the files so that we can examine it?

It happens with any of my music files. The error pops up at some point during the song, it does vary. It then won't play the next song until you acknowledge the error message.
Do you want me to upload a file to Dropbox so you can examine it?
0 Kudos
RokuDale
Level 8

Re: Issue playing audio from USB Roku Media Player

I suspect the wma files are triggering the problem. The wma file will play, but before it ends, a error dialog will come up, stating "no video tracks".
If you create a directory of just mp3 files, I suspect they will all play back fine.
If you create a directory with one of the wma files. I suspect it will have an error during playback.
0 Kudos
baxio
Level 7

Re: Issue playing audio from USB Roku Media Player

"RokuDale" wrote:
I suspect the wma files are triggering the problem. The wma file will play, but before it ends, a error dialog will come up, stating "no video tracks".
If you create a directory of just mp3 files, I suspect they will all play back fine.
If you create a directory with one of the wma files. I suspect it will have an error during playback.

No, it does the same on both MP3 and WMA albums.
The same files were playing fine in November last year, then it seems one of the software updates in December has caused the issue
0 Kudos
makaiguy
Level 11

Re: Issue playing audio from USB Roku Media Player

"RokuDale" wrote:
I suspect the wma files are triggering the problem. The wma file will play, but before it ends, a error dialog will come up, stating "no video tracks"..

I am seeing this with wma files which used to play without error.  When I convert them to mp3 they run without error.  Most of my audio files are mp3s, but I have some wmas scattered in dozens of folders so finding them to convert them is a time consuming pain in the nether regions.
Ver 9.0.0. Build 4142
RMP Ver 4.1, build 1609
Roku 3, 4200X, Ser 4124C7087583, wifi connected - Samsung UN55ES6100
Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi connected - JVC EM37T
0 Kudos