Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
ioan
Level 7

IP Camera Viewer version 4 is ready for beta testing

Get the Pro here: https://my.roku.com/add/IPCAMVIEWBASIC (free)

New in this version:

  • ONVIF Auto Config when adding a camera - if your camera is ONVIF compliant, it will find and configure the URL for streaming and PTZ (if your camera has PTZ).

  • RTSP support for jpeg encoded video stream

  • Motion detection

  • Completely rewritten stream decoding algorithm, you will see a major boost in frames/second

  • New design/simplified Add Camera window


Major fixes in this version:

  • If stream connection is lost, the software will reconnect automatically

  • Fixes the problem where for some users the application menu didn't appear

  • Fixes connection issues with Amcrest cameras

  • Other fixes and performance improvements

NOTE: If you are trying this version on a Amcrest camera, make sure you have the SubStream enabled and configured as mjpeg. The application uses rtsp to pull jpeg stream and ONLY works if your SubStream is mjpeg.

The new Add Camera with ONVIF Auto Config:





Motion Detection:

https://github.com/e1ioan/
http://rokucam.com
0 Kudos
38 Replies
Zelnor58
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

My installation just updated to Version 4, Build 37 and two of my three cameras have quit working. 

These are D-Link 932L and D-934L.  Both cameras use the same stream URL: /image/jpeg.cgi.  

The cameras are working fine when I access them through other software. Any idea of what might be going on?

Thanks for any advice.
0 Kudos
ioan
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"Zelnor58" wrote:
My installation just updated to Version 4, Build 37 and two of my three cameras have quit working. 

These are D-Link 932L and D-934L.  Both cameras use the same stream URL: /image/jpeg.cgi.  

The cameras are working fine when I access them through other software. Any idea of what might be going on?

Thanks for any advice.

When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?
https://github.com/e1ioan/
http://rokucam.com
0 Kudos
Zelnor58
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"ioan" wrote:
Zelnor58:
When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?

Yes (although the software seems to automatically add a "?" to the end). All other fields look normal.
0 Kudos
ioan
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"Zelnor58" wrote:
"ioan" wrote:
Zelnor58:
When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?

Yes (although the software seems to automatically add a "?" to the end). All other fields look normal.

Can you try adding a new camera, just for testing and use the same information just to see if a new camera will work?
https://github.com/e1ioan/
http://rokucam.com
0 Kudos
Zelnor58
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"ioan" wrote:
"Zelnor58" wrote:
"ioan" wrote:
Zelnor58:
When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?


Can you try adding a new camera, just for testing and use the same information just to see if a new camera will work?

Interesting results:  if I Add (actually I am re-adding an existing camera), I can get the view to show up ONCE, either when I "Test Config" or using the main menu options. But subsequently, when I revisit the same camera it never works. 
0 Kudos
ioan
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"Zelnor58" wrote:
"ioan" wrote:
"Zelnor58" wrote:
"ioan" wrote:
Zelnor58:
When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?


Can you try adding a new camera, just for testing and use the same information just to see if a new camera will work?

Interesting results:  if I Add (actually I am re-adding an existing camera), I can get the view to show up ONCE, either when I "Test Config" or using the main menu options. But subsequently, when I revisit the same camera it never works. 

I sent you a private message
https://github.com/e1ioan/
http://rokucam.com
0 Kudos
ioan
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"Zelnor58" wrote:
"ioan" wrote:
"Zelnor58" wrote:
"ioan" wrote:
Zelnor58:
When you edit the cameras, does the /image/jpeg.cgi still shows in the Stream URL field?


Can you try adding a new camera, just for testing and use the same information just to see if a new camera will work?

Interesting results:  if I Add (actually I am re-adding an existing camera), I can get the view to show up ONCE, either when I "Test Config" or using the main menu options. But subsequently, when I revisit the same camera it never works. 

Also, another thing to try, use: /video/mjpg.cgi see if that works
https://github.com/e1ioan/
http://rokucam.com
0 Kudos
bigKen2
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

I installed 2.7 with raspberry pi 3 , no problems and had 4 ONVIF cameras working. 
I started to get freezing and time-outs , moving the rpi from wifi to a wired connectionSolved the problem.
 
While I was working on it  IP Cam Ver 4.0 build 37 installed .
A nice surprise !  
 
It detected all 4 cameras, is now quicker and the kids have a RetroPie to play with.  
 
Very nice work ioan!
 .ps cameras are ONVIF  Lorex and SWANN  branded Hikvision DS-2CD2032
0 Kudos
ioan
Level 7

Re: IP Camera Viewer version 4 is ready for beta testing

"bigKen2" wrote:
I installed 2.7 with raspberry pi 3 , no problems and had 4 ONVIF cameras working. 
I started to get freezing and time-outs , moving the rpi from wifi to a wired connectionSolved the problem.
 
While I was working on it  IP Cam Ver 4.0 build 37 installed .
A nice surprise !  
 
It detected all 4 cameras, is now quicker and the kids have a RetroPie to play with.  
 
Very nice work ioan!
 .ps cameras are ONVIF  Lorex and SWANN  branded Hikvision DS-2CD2032

It's very good to hear about good experiences, usually I only hear from people with problems. Thank you so much! I'm very happy you like it.

PS: don't forget to give it a rating in the channels store
https://github.com/e1ioan/
http://rokucam.com
0 Kudos