Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
frankmahon
Level 8

I can't run the YouTube app on my Roku 4 (4400X). Error message: "Can't run channel".

Jump to solution

I've gone through the forum but as of September 30th I cannot find a fix for this issue.  When I click on the icon for YouTube a circular percentage indicator pops up but never reaches 100%.  At different points in the percentage count-up I get the error message "Can't run channel".  I tried uninstall and reinstalling the app with the same results.

0 Kudos
1 Solution

Accepted Solutions
frankmahon
Level 8

Re: I can't run the YouTube app on my Roku 4 (4400X). Error message: "Can't run channel".

Jump to solution

HAZAHA!  I found the solution!  Well, at least for me.  Thanks DBDukes for the assist.  Here's what I did:

1) Uninstalled the YouTube app from my Roku.

2) Unplugged the power supply cord.

3) REMOVED THE MEMORY CARD. <-this did the trick

4) Powered back on.

5) Reinstalled the YouTube app (which took a very long time without the memory card).

After testing for a while I powered off and reinstalled the memory card and it still works.  MUCH faster now.  Thanks again DBDukes!  Someone please post this in an obvious area for other Roku owners with memory cards.

View solution in original post

3 REPLIES 3\
DBDukes
Community Streaming Expert

Re: I can't run the YouTube app on my Roku 4 (4400X). Error message: "Can't run channel".

Jump to solution

@frankmahon wrote:

... I tried uninstall and reinstalling the app with the same results.


Did you reboot in between? The correct process is:

  1. Uninstall the app
  2. Reboot the Roku
  3. Reinstall the app

Anything else won't do.

DBDukes
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee.
0 Kudos
frankmahon
Level 8

Re: I can't run the YouTube app on my Roku 4 (4400X). Error message: "Can't run channel".

Jump to solution

Hi:  I did that.  I uninstalled the YouTube app, rebooted the Roku, the reinstalled the YouTube app.  Still no joy.  Thanks for the suggestion though.  Anything else I can try?

0 Kudos
frankmahon
Level 8

Re: I can't run the YouTube app on my Roku 4 (4400X). Error message: "Can't run channel".

Jump to solution

HAZAHA!  I found the solution!  Well, at least for me.  Thanks DBDukes for the assist.  Here's what I did:

1) Uninstalled the YouTube app from my Roku.

2) Unplugged the power supply cord.

3) REMOVED THE MEMORY CARD. <-this did the trick

4) Powered back on.

5) Reinstalled the YouTube app (which took a very long time without the memory card).

After testing for a while I powered off and reinstalled the memory card and it still works.  MUCH faster now.  Thanks again DBDukes!  Someone please post this in an obvious area for other Roku owners with memory cards.

View solution in original post