Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Orwell
Level 7

Hulu is skipping to next episode randomly 3/4 through every show

I have had Roku for over a decade now since the first box.  Probably on my 12th device.  Just added Hulu to my account and over the last month it has declined to every show stopping at the 3/4 mark and skipping to the next episode.  No error, no warning, just skips to 3/4 into a show I wasn't watching and starts playing.  So maddening I'm considering other streaming devices for the first time in a decade.  I can't be the only person seeing this programming glitch.  Is there a solution or is it time to start looking around.

6 Replies
PattonD
Level 7

Re: Hulu is skipping to next episode randomly 3/4 through every show

Same issue here

0 Kudos
Shann77
Level 7

Re: Hulu is skipping to next episode randomly 3/4 through every show

Same here ☹️can't figure out how to make it stop.

0 Kudos
Rockymount1
Level 7

Re: Hulu is skipping to next episode randomly 3/4 through every show

Same issue here.  Has anyone gotten any response from Roku tech support 

0 Kudos
Shann77
Level 7

Re: Hulu is skipping to next episode randomly 3/4 through every show

Haven't heard from tech support but we did find if you turn off auto play in settings it stops. 

TGH
Level 7

Re: Hulu is skipping to next episode randomly 3/4 through every show

I have the same issue. I noticed it while watching Normal People series on Hulu. I am new to Hulu. By chance is this occuring only on particular Hulu Series or is it system wide on Hulu.  I have not noticed on any other such as Prime Video or Netflix

0 Kudos
Cnh-320
Level 8

Re: Hulu is skipping to next episode randomly 3/4 through every show

Turning autoplay off in each profiles settings helped me too. 

0 Kudos