Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
hojo1690
Level 8

Re: Disney+ still not working on Roku Ultra POST-fix

Well, you can wait, and live without Disney+, and degraded performance of everything on your home network because you have a bad DNS server in your configuration, you could fix your DNS server path, improve your performance and have Disney+ back immediately.  When they finally fix the App, it won't be a problem if your DNS breaks again.

But yanno, if you'd rather complain and not watch Disney+, and have bad network performance, I guess that's a good choice for you, too.

BobbyDaddy
Level 8

Re: Disney+ still not working on Roku Ultra POST-fix

Thank you.  You took the words out of my mouth.  You can lead a horse to water...

0 Kudos
Spazimspaz
Level 7

Re: Disney+ still not working on Roku Ultra POST-fix

I've got 7 devices and none get Disney plus. Hulu works decently. Ive attempted to change my DNS using 1.1.1.1 and 8.8.8.8 as the primary and secondary but it's not working. Updated, cleared the cache, restarted more than I care to admit and nothing. I'm running an Asus router... Maybe I'm changing the DNS in the wrong spot?

0 Kudos
DoomShizzle
Level 7

Re: Disney+ still not working on Roku Ultra POST-fix

Same issue, followed the DNS change instructions numerous times and still error 42 on Disney plus. All other channels work fine. 

0 Kudos
Slowlemur
Level 7

Re: Disney+ still not working on Roku Ultra POST-fix

I have three devices, an Ultra, a Playbar, and a Streaming Stick, which all exhibit the same behavior so it's not Ultra specific.  I have also tried updating the primary DNS on the router and that didn't seem to help.

However, if I turn my phone into a hotspot and connect the Roku to THAT, and then tried Disney+, it WORKS!   THEN, I reconnect it to my home network and then Disney+ works fine.  It seems to cache whatever lookup it needed until I restart my Roku, in which case I get the Error 42 again.

I also had this issue before and it was fixed when they revered back to 10.3...but after they forced the update to 10.5.0, the problem came back.

0 Kudos
3rando
Level 8

Re: Disney+ still not working on Roku Ultra POST-fix

So there's more than one place in the web interface of your router where you'll encounter DNS entries. What you're looking for specifically is the DHCP service options, typically under LAN, Local Network, whatever your router calls the local area network. If you don't see an option, check under advanced settings. Once you find the DHCP service, you're going to change the first dns ip address to a known working one (1.1.1.1, 8.8.8.8, ect). If you've already tried using one of the servers I listed, try the other one. Once you make this config change, reboot the roku device and test. If its still not working/you've already done all the above, try rebooting the router and the roku and see if that does the trick.

0 Kudos
EightRainDeer
Level 7

Re: Disney Plus not working - Error Code 42

+1.  Son of a gun.  DNS it is!  I've got two routers, the one from my ISP and then a Ubiquiti behind that to handle some segmentation.  The DNS on the latter unit were set to the IPs for OpenDNS.  Switching them to 8.8.8.8 and 9.9.9.9, reboot the Roku, and BAM, works like a champ.

Thank you!

0 Kudos
labgirl221
Level 7

Re: DISNEY + ERROR 42, DICOVER + ERROR AFTER 10.5.0 SOFWARE UPDATE

any fix to this yet?  still no luck for me with either company customer service.  error code 42 on roku ultra but works on other non roku devices- HELP!  it has been weeks!

0 Kudos
Spazimspaz
Level 7

Re: DISNEY + ERROR 42, DICOVER + ERROR AFTER 10.5.0 SOFWARE UPDATE

So I did actually fix this. I went to WAN and under DCHP I adjusted my DNS provider to 1.1.1.1 I did at one point have a pihole providing the DNS and never reverted back so this may have been the problem. I also went into the LAN settings and added 1.1.1.1 and 8.8.8.8 to the DNS providers. I run a main router with 4 mesh nodes so Im assuming since the mesh runs off the LAN settings this may have effected it as well. 

 

As a side note it also restored my Google nest speaker's ability to turn off the Roku device. I'm guessing the new update and the Disney channel do not have a fall back DNS provider where as everything else in my house does. I'm running an Asus router by the way.

0 Kudos
Musoka
Level 10

Re: DISNEY + ERROR 42, DICOVER + ERROR AFTER 10.5.0 SOFWARE UPDATE

Yes, this failure to rollover DNS was discussed by a few of us on page 7-9. Roku has been given the answer by their USERS, to the problem they created nearly 3 weeks ago now. Horrible company that has multiple times now left things broken for me for months... No more roku in this house

0 Kudos